Support Questions
Find answers, ask questions, and share your expertise

How do i disable or set to null ssl.endpoint.identification.algorithm in Nifi.

How do i disable or set to null ssl.endpoint.identification.algorithm in Nifi.

New Contributor

How do i disable or set to null ssl.endpoint.identification.algorithm in Nifi.

Currently using SSL via certificates as well as Schema Registry url-StandardRestrictedSSLContextService

 

Error is : 

SSL Handshake failed: org.apache.kafka.common.errors.SslAuthenticationException: SSL handshake failed org.apache.kafka.common.errors.SslAuthenticationException: SSL handshake failed

Caused by: java.security.cert.CertificateException: No name matching xxx. found

----------------------

sasl.login.class = null
sasl.login.refresh.buffer.seconds = 300
sasl.login.refresh.min.period.seconds = 60
sasl.login.refresh.window.factor = 0.8
sasl.login.refresh.window.jitter = 0.05
sasl.mechanism = GSSAPI
security.protocol = SSL
send.buffer.bytes = 131072
session.timeout.ms = 10000
ssl.cipher.suites = null
ssl.enabled.protocols = [TLSv1.2, TLSv1.1, TLSv1]
ssl.endpoint.identification.algorithm = https
ssl.key.password = [hidden]

 

-------------

 

 

Please suggest.

@Nifi @kafka