Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

New Contributor

I am following the tutorial at

https://hortonworks.com/tutorial/predicting-airline-delays-using-sparkr/#step-2--setup-sparkr-on-rst...

It requires installation of RSTUDIO.

I can download the file

wget https://download2.rstudio.org/rstudio-server-rhel-1.0.153-x86_64.rpm 

I am getting error while installing .

sudo yum install --nogpgcheck rstudio-server-rhel-1.0.153-x86_64.rpm

Have included the image of error.

Please guide. I am new to HDP sandbox and Hadoop too.

I am using HDP-2.6.1 on virtual box and CENTOS 7


error.png
5 REPLIES 5
Highlighted

Re: How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

Super Guru

are you following this install step?

https://community.hortonworks.com/content/kbentry/69424/setting-up-rstudio-on-hortonworks-docker-san...

It worked for me.

What VM? Vmware? VirtualBox? Docker? What host os? Windows? OSX?

How much RAM do you have.

Highlighted

Re: How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

Super Guru

you need to follow the sandbox installation guide to make sure all the ports are open and you are allowed to access the internet from the sandbox.

make sure you follow full networking info

https://hortonworks.com/tutorial/sandbox-port-forwarding-guide/section/3/

Highlighted

Re: How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

Explorer

to get around this error go to /etc/yum.repos.d and mv the file sandbox.repo out of this folder into some other folder and then do the yum install

Highlighted

Re: How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

New Contributor

Awesome!!!! It worked. Thanks @jnarayanan . Great help.

@Timothy Spann thanks for trying to help. Appreciate it. I was using 8 gb ram. Other details posted in question.

Highlighted

Re: How to Install Rstudio on HDP SANDBOX 2.6.1 ,CENTOS 7 ?

Super Guru

You need to make sure networking is working and all ports are open. firewall is off.

i can install this no problem

Don't have an account?
Coming from Hortonworks? Activate your account here