Support Questions
Find answers, ask questions, and share your expertise

How to disable PERFLOG in hiveserver2

Solved Go to solution

How to disable PERFLOG in hiveserver2

Contributor

Hi All,

Hiveserver2 is creating huge log files sometime TB size.Perflogger is enabled .Also level of logging in INFO. .

How do i disable Perflog and make logging level to WARN or ERROR

1 ACCEPTED SOLUTION

Accepted Solutions

Re: How to disable PERFLOG in hiveserver2

add these lines to hive-log4j.properties

  • logger.PerfLogger.name = org.apache.hadoop.hive.ql.log.PerfLogger
  • logger.PerfLogger.level = DEBUG

View solution in original post

1 REPLY 1

Re: How to disable PERFLOG in hiveserver2

add these lines to hive-log4j.properties

  • logger.PerfLogger.name = org.apache.hadoop.hive.ql.log.PerfLogger
  • logger.PerfLogger.level = DEBUG

View solution in original post