Support Questions

Find answers, ask questions, and share your expertise

How to remove configuration setting on Hbase?

New Contributor

Currently I have a table with settings that look like this:

hbase(main):020:0> describe 'my_table'
Table my_table is ENABLED                                                                                                                                                                      
hdfs_storage_metadata, {CONFIGURATION => {'' => 'kafka:6667,kafka1:6667,kafka2:6667', '
' => 'Kafka-topic', 'kafka.some.topic' => 'some-coprocessor'}}                                                                                                                  
COLUMN FAMILIES DESCRIPTION                                                                                                                                                                                 
CKCACHE => 'true', BLOCKSIZE => '65536', REPLICATION_SCOPE => '1'} 

However, I am trying to enable cross-cluster replication and am getting an error because my configuration settings are not the same for these tables. I need to remove the CONFIGURATIONsetting, but I cannot find a method with which to do it. I have looked at the documentation and have tried

alter 'my_table', METHOD => 'table_att_unset',NAME => 'CONFIGURATION'

But I get that CONFIGURATION cannot be found. From the hbase-shell documentation, I tried

alter 'my_table', METHOD => 'table_conf_unset',NAME => 'CONFIGURATION'

But got that table_conf_unset could not be found. Is this something I can even do? I am not sure what other methods are possible.

I am running hbase version


Hi @Nick Predey!
I'm not very used to Hbase, but could you share the error that you're getting from hbase-shell?

New Contributor

I get the error: `Could not find attribute:`. It seems that the setting `CONFIGURATION` cannot be found for some reason.

you can unset each configuration separately like this:-

alter 'my_table', METHOD => 'table_conf_unset', NAME => ''

alter 'my_table', METHOD => 'table_conf_unset', NAME => ''

alter 'my_table', METHOD => 'table_conf_unset', NAME => 'kafka.some.topic'

New Contributor

When I do this, I get `Could not find attribute:`.

can you try 'table_conf_unset' instead of 'table_att_unset', I just updated my answer.

New Contributor

With that I get `Unknown method: table_conf_unset`. I am not sure if that is because of my version or not.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.