Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HttpFS access issue

HttpFS access issue

New Contributor

I am trying to configure HttpFS on Cloudera V5.3.1  . The HttpFS service is running.

I tried the command curl "http://<hostname>:14000/webhdfs/v1/tmp?op=LISTSTATUS&user.name=user" . It is listing properly

When I try to run the same comamnd without providing user.name, it is giving

<body><h1>HTTP Status 401 - Authentication required</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Authentication required</u></p><p><b>description</b> <u>This request requires HTTP authentication.</u></p>

 

Tried the same from REST client, by providing basic authorization (username/password), still I get same issue.

What changes I need to do, to get it working ? Do I need to update something in the config file ?

Your help is very much appreciated as I am blocked.

Thanks

Deepa

1 REPLY 1

Re: HttpFS access issue

Master Guru
Could you share your REST Client code? In a non-kerberos mode, you only need to ensure passing the parameter user.name indicating the user you want to connect as.

In kerberos mode, this can be omitted as it would be inferred from the Kerberos TGT instead.