Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hue/Oozie Time settings

Hue/Oozie Time settings

New Contributor

Hello!

 

I have a question regarding Hue and TimeZone settings.

 

We have experienced a problem on our production environment.

We have a 11 node cluster and our time zone is set to Europe/Belgrade. We have around 15 MapReduce jobs scheduled to run every two hours, but at even hours. This is important because of our polling schedule.

 

After the Daylight Saving Time changed in October (time was set an hour earlier), our Map Reduce jobs started running at every odd hour.

Is there a way to fix this?

 

Is this a known issue/bug in Hue or there is a possible setting we missed?

 

Thank you in advance.

 

2 REPLIES 2
Highlighted

Re: Hue/Oozie Time settings

Super Collaborator

Hi,

 

How are scheduled theses jobs ?

If using oozie coordinators then it is more an oozie issue.

 

And I don't think oozie work well with daylight saving time.

Guess the workaround is to "reinstall" the coordinators.

 

regards,

Mathieu

Re: Hue/Oozie Time settings

New Contributor

Hi.

 

 

Yes, jobs are scheduled as Oozie Coordinators.

The problem is that job description say that the job will be executed at every even hour, but job starts executing at every odd hour.

 

Do you know any other way to fix this, since this happened on our production environment and "reinstalling" would take a lot of time which could lead to downtime?

 

 

Thank you in advance.

Don't have an account?
Coming from Hortonworks? Activate your account here