Support Questions

Find answers, ask questions, and share your expertise

Hue with Impala "Enable LDAP Authentication" - TSocket read 0 bytes

New Contributor

Hello guys,

1. When I enable the authentication on impala service 




2. I try to connect with impyla and I'm able to see data : 



from impala.dbapi import connect
conn = connect(host='', database='db_grp1', port=21050, auth_mechanism="LDAP",user='user1', password="password1")

cursor = conn.cursor()
cursor.execute('select * from table1 ;')
results = cursor.fetchall()
print (results)
$ python3 
[(1, 'one'), (2, 'two'), (3, 'three')]


3. But on HUE I'm not able to retreieve data, if I disable the authentication, I can see again my table. (I have configured HUE to authenticate through LDAP and I'm able to authenticated successfully) 

Here is the error




Is that possible on HUE to "authenticate again" to impala to retrieve data ? 


Kind Regards




After you enabled LDAP for Impala, have you tried to do the same in Hue's configuration for Impala?

See below doc:

Enabling LDAP for Impala in Hue
1. Go to the Hue service.
2. Click the Configuration tab.
3. Select Scope > Hue Server.
4. Select Category > Advanced.
5. Add the following properties to the Hue Server Advanced Configuration Snippet (Safety Valve) for hue_safety_valve_server.ini property.

auth_username=<LDAP username of Hue user to be authenticated>
auth_password=<LDAP password of Hue user to be authenticated>

6. Click Save Changes.