Support Questions
Find answers, ask questions, and share your expertise

I am installing apache metron on single node full dev installation. ambari server is up but it is showing some error in vagrant provision

New Contributor

TASK [ambari_gather_facts : set_fact] ****************************************** fatal: [node1]: FAILED! => {"failed": true, "msg": "ERROR! 'dict object' has no attribute 'core-site'"} PLAY RECAP ********************************************************************* node1 : ok=66 changed=15 unreachable=0 failed=1 Ansible failed to complete successfully. Any error output should be visible above. Please fix these errors and try again

9 REPLIES 9

Super Mentor

New Contributor

I have tried for these but still it is giving me same error. I dont know what it is related to.

Super Mentor

@Pratik Deshmukh

can you please share the complete log.

Also if you can share little background of this issue like how you build it and how you are trying to start , then it will be very helpful.

New Contributor

Super Collaborator

@Pratik Deshmukh, in addition to the full log that @Jay SenSharma asked for, can you also run metron-deployment/scripts/platform-info.sh and provide the output

New Contributor

This is what i got after running the script @asubramanian

[root@workstation scripts]# ./platform-info.sh Metron 0.4.0 ./platform-info.sh: line 30: git: command not found -- ansible 2.0.0.2 config file = /etc/ansible/ansible.cfg configured module search path = Default w/o overrides -- Vagrant 1.9.5 -- Python 2.7.5 -- Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T22:11:47+05:30) Maven home: /opt/maven Java version: 1.8.0_131, vendor: Oracle Corporation Java home: /opt/jdk1.8.0_131/jre Default locale: en_US, platform encoding: UTF-8 OS name: "linux", version: "3.10.0-514.21.2.el7.x86_64", arch: "amd64", family: "unix" -- Docker version 17.05.0-ce, build 89658be -- node ./platform-info.sh: line 69: node: command not found -- npm ./platform-info.sh: line 74: npm: command not found -- Linux workstation.example.com 3.10.0-514.21.2.el7.x86_64 #1 SMP Tue Jun 20 12:24:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux -- Total System Memory = 15787.2 MB Processor Model: Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz Processor Speed: 3330.250 MHz Processor Speed: 3310.500 MHz Processor Speed: 3316.125 MHz Processor Speed: 3302.750 MHz Total Physical Processors: 4 Total cores: 16 Disk information: /dev/mapper/cl-root 50G 26G 25G 51% / /dev/sda1 1014M 230M 785M 23% /boot /dev/mapper/cl-home 407G 33M 407G 1% /home

Super Collaborator

Hmm.. can you try and match the pre-requisites from here - https://github.com/apache/metron/tree/master/metron-deployment/vagrant/full-dev-platform#prerequisit...

I see these in your output

line 30: git: command not found
-- Vagrant 1.9.5

That said, have you attempted to re-provision the full-dev setup? I've seen at times that Metron full dev fails sometimes if I let my system screensaver to turn on (weird yup, but I've seen it). And then I would do - vagrant destroy, followed by vagrant up again to get it working.

Contributor

I believe the python version should be 2.7.11 +

New Contributor

Is it really needed ? @Otto Fowler

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.