Support Questions
Find answers, ask questions, and share your expertise

I can't access the NIFI


all of sudden ,

the NIFI goes down and I can't access it ,

when I checked the status I found the following :[root@hdf ~]# /usr/NIFI/nifi- status JAVA_HOME not set; results may vary

Java home:
NiFi home: /usr/NIFI/nifi-

Bootstrap Config File: /usr/NIFI/nifi-

2018-03-28 09:27:47,447 INFO [main] org.apache.nifi.bootstrap.Command Apache NiFi is running at PID 21028 but is not responding to ping requests

the logs attached as well.

I tried to restart the NIFI and restart the machine itself which hosting the application, with no success.

given that it's a standalone application.

another symptom:

[root@hdf ~]# netstat -anopl | grep 8080
tcp        0      0  *               LISTEN      21028/java           off (0.00/0/0)
tcp        0      0      CLOSE_WAIT  21028/java           off (0.00/0/0)
tcp        0      0      ESTABLISHED 21028/java           off (0.00/0/0)
tcp        1      0      CLOSE_WAIT  21028/java           off (0.00/0/0)
tcp        0      0      FIN_WAIT2   21028/java           off (0.00/0/0)
tcp        1      0      CLOSE_WAIT  21028/java           off (0.00/0/0)

any clue experts??!!


Cloudera Employee


Please check if your disk didn't got full, I had similar issue a while back. I see lot of Errors on your log

ue to java.lang.RuntimeException: Timed out while executing one of processor's OnScheduled task.; processor will not be scheduled to run for 30 seconds: java.lang.RuntimeException: Timed out while executing one of processor's OnScheduled task.


thanks a lot for your response but I believe this is not my case :

[root@hdf ~]# df -h
Filesystem                   Size  Used Avail Use% Mounted on
/dev/mapper/centos_hdf-root  462G  213G  249G  47% /
devtmpfs                     1.8G     0  1.8G   0% /dev
tmpfs                        1.9G   84K  1.9G   1% /dev/shm
tmpfs                        1.9G  9.0M  1.9G   1% /run
tmpfs                        1.9G     0  1.9G   0% /sys/fs/cgroup
/dev/sda2                    497M  158M  339M  32% /boot
tmpfs                        372M   16K  372M   1% /run/user/42
tmpfs                        372M     0  372M   0% /run/user/0


Can you first set your JAVA_HOME and retry you are better doing that in the .profile or bashrc

Hope that helps

Super Guru

That's an old version, update to HDF 3.1 / NiFi 1.5.

Make sure your JDK is working, there is enough space.

Check the logs sometimes a bad flow will keep you from running.

YOu can change the properties to not autostart and that will help.

You can also delete the cached flow.xml.gz if you don't care about the flows and that cleans things up.

You can also wipe out your repositories.



@Timothy Spann

great tip thanks a lot, but I believe I run into another issue after opening the UI I believe that the processors process nothing ?!!!!!

they are not working

Master Guru
@Mahmoud Shash

It appears you may have run into

My suggestion would be to try setting the following file property to false:


Then start your NiFi Flow.

NiFi should start with all you processors in a stopped state and you should be able to access your NiFi UI.

From there look for any invalid processors on your canvas, select them and click the "disable" icon (looks like a lightning bolt with a line through it) in the operate panel.

It is likely some misconfigured or invalid processor is causing some hung scheduling threads. There is a limited number of these threads and if they all become hung, no other processors will be able to start which would explain all the various processor timeouts you are seeing.

Not saying that these are the problematic processors, but a good place to start.



Trying disabling these processors and see if Nifi will restart with everything else still running.


I also question why you have some processors in your flow configured to use 100 concurrent tasks:

- UpdateAttribute[id=667d1488-41c6-14d7-f4c3-51b659877396] to run with 100 threads
- PutKafka[id=667d1484-41c6-14d7-e6b0-4b768bca030e] to run with 100 threads
- PutKafka[id=5dad2e4c-0162-1000-9875-acb359a8d298] 

You should consider dialing these back.
You should also take a look at your configured "Max Timer Driven Thread Count" setting under controller settings to make sure they are aligned well with your hardware for CPU utilization.



; ;