Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

I compiled hdp oozie 2.5.0.0 with spark2 version. But how to bring that to HDP 2.5.0.0 package.

I compiled hdp oozie 2.5.0.0 with spark2 version. But how to bring that to HDP 2.5.0.0 package.

New Contributor

Backgroud: I want to use ambari to manage. But HDP oozie 2.5.0.0 cannot support spark2 task. So I want to recompile HDP oozie which could support spark2 and I made it. And then I need to update this into HDP 2.5.0.0 package, the question is I don't know how to update this into HDP 2.5.0.0 package.

1,There are two HDP oozie rpms in HDP 2.5.0.0 package.

10506-1.png

2,I've compiled HDP oozie 2.5.0.0 with spark2 successfully.

10508-2.png

3, So how could I create these two rpms and then I can substitute those two into my HDP package?

3 REPLIES 3

Re: I compiled hdp oozie 2.5.0.0 with spark2 version. But how to bring that to HDP 2.5.0.0 package.

New Contributor

Firstly, extract spec file from your HDP rpm by `rpmrebuild`.

Secondly, try `diff` with your old and new source code. `diff -uNr ./hive-release-HDP-2.5.0.0-tag ./hive-release-HDP-2.5.0.0-tag-new > yours.patch`

Thirdly, bring your patch into the spec file , and then `rpmbuild`.

Re: I compiled hdp oozie 2.5.0.0 with spark2 version. But how to bring that to HDP 2.5.0.0 package.

New Contributor

@Lawrence Lau i have the same case with you, but i don't know how to rebuild hdp-oozie, can you help me? WebChat:38798579 StevenChennet@live.com

Re: I compiled hdp oozie 2.5.0.0 with spark2 version. But how to bring that to HDP 2.5.0.0 package.

New Contributor

would you please mail me your oozie rpm files. stevenchennet@live.com

Don't have an account?
Coming from Hortonworks? Activate your account here