Support Questions
Find answers, ask questions, and share your expertise

I have got a warning: Derby is not recommended for production use. With Derby, Oozie server HA and concurrent connection support will not be availibale.

Contributor

I didnt see place Derby was in the list, so what I do for this warning?

2 ACCEPTED SOLUTIONS

Mentor

@Robin Dong

By default uses an Ambari-installed Derby instance which is not robust for production hence HA

The recommended DB's are

 - PostgreSQL 8 and above
- MySQL 5.6 
- Oracle 11gr2, 12c

Configuring non-default databases

More doc

View solution in original post

Mentor

reinstall-the-mysql.pdf@Robin Dong

You pick it when you launch the ambari-server setup

see attached doc database vendor please see the reinstall first

View solution in original post

6 REPLIES 6

Mentor

Use any other database vendor that is supported, you have a wide choice http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_HDP_Reference_Guide/content/ch_supported_...

Contributor

Thanks Artern. can you let me know any where I can pick database vendor during the ambari installation.

or I can go ahead to process and change the to other database vendor later?, I guess not 🙂

Mentor

For some products switching default db is easier than others. Please refer to our documentation to configure database and save yourself hours of grief figuring it out on your own.

Mentor

@Robin Dong

By default uses an Ambari-installed Derby instance which is not robust for production hence HA

The recommended DB's are

 - PostgreSQL 8 and above
- MySQL 5.6 
- Oracle 11gr2, 12c

Configuring non-default databases

More doc

Mentor

reinstall-the-mysql.pdf@Robin Dong

You pick it when you launch the ambari-server setup

see attached doc database vendor please see the reinstall first

Contributor

thank you both. yes at ambari-server setup.

; ;