Support Questions
Find answers, ask questions, and share your expertise

I'm getting a server error when I attempt to access maria_dev

New Contributor

I'm using Virtual Box with HDW 2.5. After resolving some issues with a port conflict, I was able to successfully log into maria_dev. I come back 24 hours later and I get a server error when I attempt to log in with my Chrome browser. Same error with raj_dev. I was able to log into the root from within Virtual Box and change the admin password. Any suggestions on why I'm seeing an error? I've cleared the browser cache.


Super Mentor

@Robert Geiger

Can you please explain what do you mean by "server error when I attempt to log in with my Chrome browser." ?

Did you notice any error on "/var/log/ambari-server/ambari-server.log" when you attempted to login to Ambari later?

Also please let us know if for 24 hours have you put your system on Hibernate( Suspended Mode) Or shutdown your VM normally? This is important to now because sometimes suspending a VM causes N/W services to not resume properly and hence it might cause some issues on Ambari side.

New Contributor

Hi Jay, thanks for your response. Disclaimer up front... I'm very new to all of this so please bear with me.

I downloaded and set up HDP_2.5_virtualbox.ova for a class I'm taking. I could not get the Ambari interface to load (Access Error: 404 -- Not Found) so thinking it was a version issue, I downloaded and set up HDP_2.6.3_virtualbox_16_11_2017.ova and got the same results. Eventually, I figured out I had a port conflict that was preventing the Ambari login from appearing. I resolved the conflict and was able to log into Ambari with 2.5. 24 hours later I went back in, got to the same login, and this time I got a message that said "Server Error". Being very new to this, I don't know where to go to check the log. I was able to use GIT BASH to change the admin password on the root but that was about it.

I just now tried going into my 2.6.3 instance and after attempting to log in through my browser and getting a conflict, I performed the suggested hard reset (CTRL SHIFT R) and Ambari loaded successfully. This does not fix my issue with 2.5 however. Maybe not a big deal if I can use 2.6.3 but would be nice to know what I screwed up so i don't do it again.

To answer your questions, I have put my system in sleep mode since yesterday but I always shutdown VM by powering off the box and then closing Virtual Box before doing so.

Super Mentor

@Robert Geiger

Different HDP sandbox versions ships different version of Ambari.

Many times the Ambari offline javascripts files are also gets stored on the Browse cache. These javascripts are slightly different in Amabri 2.6 and Ambari 2.5 versions and the Client Version do not match which can cause a silent error "Ambari Server and Web Client versions do not match"

So it can cause login failure or login issues when we move from Ambari 2.5 to Ambari 2.6 on the same browser (when the Ambari URL remains same) So in order to avoid the Java Script conflicts we must do a "CTRL + SHIFT + R)" Hard refresh to the browser.

Similar issue is also reported here: (Even though you do not see the exact same error on your browser it might be a silent failure which makes it hard to understand/find) :