Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

New Contributor

I'm getting this error please help me


ERROR tool.ImportTool: Import failed: java.io.FileNotFoundException: File does not exist: hdfs://localhost:54310/usr/local/sqoop/lib/parquet-hadoop-1.6.0.jar

7 REPLIES 7

Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

Mentor

@Surendaran Manickam

You will need to copy that file from /usr/hdp/current/sqoop-server/lib/* to /usr/local/sqoop/lib/ but the best option will be to create a symbolic link so that all the dependencies maybe other jars are available to sqoop

Symbolic or soft link (files or directories, more flexible and self-documenting)

# Source Link

ln -s /usr/hdp/current/sqoop-server/lib  /usr/local/sqoop/lib

Which should make the parquet-hadoop-1.6.0.jar available now if you run your sqoop comamnd it should succeed

Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

New Contributor

Is this method correct and thanks for kindly reply Geoffrey Shelton Okot

109587-ipmsgclip-s-1561529212-0.png109555-ipmsgclip-s-1561528935-0.png109550-ipmsgclip-s-1561528274-0.png109549-ipmsgclip-s-1561528243-0.png

Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

Super Mentor

@Surendaran Manickam

As the Error is pointing to HDFS path (not the local file system)

File does not exist: hdfs://localhost:54310/usr/local/sqoop/lib/parquet-hadoop-1.6.0.jar

.

So can you please check if your HDFS has that JAR or the required jars? Can you try to put the required JARs there?

# su - hdfs -c "hdfs dfs -ls /usr/local/sqoop/lib/"
(OR)
# su - hdfs -c "hdfs dfs -ls hdfs://localhost:54310/usr/local/sqoop"
# su - hdfs -c "hdfs dfs -ls /usr/local"
# su - hdfs -c "hdfs dfs -ls hdfs://localhost:54310/usr/"

Also can yu please share the exact Sqoop command that you are executing ?


Other option will be to create same directory on HDFS and the put the jars there:

# hdfs dfs -put /LOCAL/PATH/TO/parquet-hadoop-1.6.0.jar  hdfs://localhost:54310/usr/local/sqoop/lib/parquet-hadoop-1.6.0.jar

.

And set the permissions of that JAR and directory properly like sqoop:hadoop so that it can be read properly.

Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

New Contributor

@Jay Kumar SenSharma

I have created a directory and added all sqoop jar to hdfs://localhost:54310/usr/local/sqoop/lib/

and Sqoop 1.4.7 jar to it at last it worked

But getting this error can you help

thanks for your kindly reply


109575-ipmsgclip-s-1561539828-0.png

Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

Mentor

@Surendaran Manickam

Yes that looks okay now you should be able to launch your sqoop job.

Please revert


Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

New Contributor

@Geoffrey Shelton Okot

No same jar problem exits when i run sqoop job.

Re: I'm importing data from windows sql server to ubuntu 18.04 using sqoop 1.4.7

Super Mentor

@Surendaran Manickam

Your current issue seems to be more specific to your custom classes "tblpaytype".

Can you please open a separate HCC thread and the provide detailed information about that "ClassNotFountError: tblpaytype" ..

That way we can isolate different issues as part of different HCC threads .. It becomes more helpful to other HCC users to quickly find the solutions.

It will be great if you can mark the most helpful answer if this HCC thread as :"Answered" by clicking the "Accept" link on that answer.