Support Questions

Find answers, ask questions, and share your expertise

I run the script/tool( and i can search the hive entities like tables, database, views, columns,but no lineage, is that nomal?

New Contributor

before install atlas, there are two hive table named atlas_testm and atlas_testm_ext(is a view based on atlas_testm) in my hive database cluster.

after install atlas and run the atlas services , i run the script named,i can saw these two hive table in atlas ui web by search,but no lineage which is relationship of atlas_testm and atlas_testm_ext,is that nomal?

i want to know whether the script named does not support hive table's history lineage import?

this problem has been bothering me for a long time.




Rising Star

Yes that's expected behavior. doesn't have the ability to track lineage.



I know this question is an old one, but I am exactly in this situation. I have Cloudera and Hive that has been filled through Hue. I created a simple data structure with a couple of tables, then joined them in order to create a third table. I then run the script to import these data into Atlas. I figure out now in this forum that import-hive script is not supporting data lineage. Indeed after script execution, data lineage for tables is empty. How can I then migrate data from Hive into Atlas, including the data lineage?


Thanks a lot for your answer.