Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala ODBC issue while connecting tableau reporting tool

Impala ODBC issue while connecting tableau reporting tool

New Contributor

Hello,

 

I am getting below list of errors while connecting Impala/Hive from Tableau. Below listed issue comes on random basis.

I will say twice in week. I am restarting tableau worker node and tableau server to fix this issue, but it is temporary solution. Could you please let me know any changes need to do in cloudera odbc drivers to resolve below listed issue

 

1) [Cloudera] [Impala ODBC] (110) Error while executing a query in Impala: [HY000]

2) [Cloudera] [Impala ODBC] (10000)  General error: unexpected execution has been caught.

3) [Cloudera] [Impala ODBC] (230) The currenct connection is trying to us the saslGSSAPI plugin but SASL library has already been configured to use the saslSSPI plugin by previous connection.

 

Thanks,

Shivaji

4 REPLIES 4

Re: Impala ODBC issue while connecting tableau reporting tool

Expert Contributor
Hi Shivaji,

What version of the ODBC driver are you using? Have you checked the impalad
logs at the times those errors occur? They should give you some hints what
queries fail and trigger those.

Cheers, Lars
Highlighted

Re: Impala ODBC issue while connecting tableau reporting tool

New Contributor

Hi,

 

Below is the Hive version I am using

 

ODBC Version: 03.80
Driver Version: 2.5.19.1004
Bitness: 64-bit
Locale: en_US

 

Below is the Impala version I am using.

 

ODBC Version: 03.80
Driver Version: 2.5.33.1004
Bitness: 64-bit
Locale: en_US

 

I am not getting any logs related to this issue from impala logs.

 

Thanks you for your suggestion.

 

Thanks,

Shivaji

Re: Impala ODBC issue while connecting tableau reporting tool

New Contributor

Hi,

 

Please let me know if there is any resolution for this issue, i am having same issue with Impala version 2.5.0 - CDH5.7.1.

 

ODBC connection is not stable with this version.

Re: Impala ODBC issue while connecting tableau reporting tool

New Contributor

Hello,

 

Did you manage to fix this issue ?

I'm facing the same problem with recent versions of Tableau, ODBC Driver and Impala...

 

Thanks