Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala Replication in Clusters

Highlighted

Impala Replication in Clusters

Explorer

Hello,

 

I am new in Impala. I have installed Cloudera Standard Version with 7 hosts. Everything works fine. Now i want to use impala for better performance. I have created tables in hive as well as hbase and replication is done in all clusters properly. I created tables on node 1 rest of all nodes also get that tables, so replication is done properly.

 

Now when i am creating table in imapla on node 1 then only node 1 will show that table. Other nodes doesn't show that newly created table until i restart services.

 

I can't understand this problem why replication is not done on all nodes properly. Please help me by providing solution of this problem as soon as possible.

 

Thanks 

Surbhi Singh

1 REPLY 1

Re: Impala Replication in Clusters

New Contributor

Hi Radius -

 

Currently metadata is not automatically updated on the other Impala nodes, for the time being, you will need to issue the "invalidate metadata" command in order to see the new tables. As far as I know, this only needs to be done on the node you are issuing the query to. 

 

See the following documentation for more information...

http://www.cloudera.com/content/cloudera-content/cloudera-docs/Impala/latest/Installing-and-Using-Im...

 

Ricky