Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala-Shell setup requires libpython2.6.so.1.0

Highlighted

Impala-Shell setup requires libpython2.6.so.1.0

New Contributor

Hi there,

 

I'm trying to setup Impala on one of my CDH(v5.6.0) cluster nodes on AWS. So far I have setup all the pre-requirements such as Java and Hive Metastore. I've gone through almost all of the Impala installation except for the last step. When I tried to install Impala-shell, it keeps saying the required libpython2.6.so.1.0 is missing. However, I do have libpython2.7 installed on my machine. Is there something I need to do to correct this issue?

 

Here's the error message:

[ec2-user@***** lib]$ sudo yum install impala-shell
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Resolving Dependencies
--> Running transaction check
---> Package impala-shell.x86_64 0:2.4.0+cdh5.6.0+0-1.cdh5.6.0.p0.112.el6 will be installed
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: impala-shell-2.4.0+cdh5.6.0+0-1.cdh5.6.0.p0.112.el6.x86_64
--> Finished Dependency Resolution
Error: Package: impala-shell-2.4.0+cdh5.6.0+0-1.cdh5.6.0.p0.112.el6.x86_64 (cloudera-cdh5)
Requires: libpython2.6.so.1.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 

Here's one of the libpython2.7 files on my machine:

[ec2-user@***** lib]$ sudo yum provides *libpython2.7*
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos

 

python-libs-2.7.5-34.el7.x86_64 : Runtime libraries for Python
Repo : @anaconda/7.2
Matched from:
Filename : /usr/share/systemtap/tapset/libpython2.7-64.stp
Filename : /usr/lib64/libpython2.7.so.1.0
Provides : libpython2.7.so.1.0()(64bit)

 

Thanks,

Roger