Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala, TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0

Impala, TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0

New Contributor

any one came across any of the below error?

 

i am trying to connect from microstrategy db tool to impala using ldap authentication.

 

I0323 16:23:24.494537 21913 thrift-util.cc:109] TThreadPoolServer: TServerTransport died on accept: invalid sasl status

2 REPLIES 2

Re: Impala, TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0

Guru
Hi,

We will need more info to see what is going on:

- are you using ODBC or JDBC
- in case JDBC, what connection strings are used
- in case of ODBC, what are the configurations for it
- have you tried to enable the TRACE log and see what errors are reported by driver?
- are you able to connect from impala-shell?
- is cluster kerberos enabled?

Re: Impala, TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0

New Contributor

Here is the odbc setting we are using.

 

[impala_db]

Driver=/MSTRfiles/Hadoop/Impala/lib/ddimpala27.so

Description=DataDirect impala wire protocol

ArraySize=1024

Database=

DefaultLongDataBuffLen=1024

DefaultOrderByLimit=-1

EnableDescribeParam=0

Hostname= LoginTimeout=30

LoginID=

MaxVarcharSize=2147483647

Password= PortNumber=21050

RemoveColumnQualifiers=0

StringDescribeType=-9

TransactionMode=0

UseCurrentSchema=0

 

trace logs are not logging anything, the only place we see error is in impala logs "TThreadPoolServer: TServerTransport died on accept: SSL_accept: error code: 0" Yes kerberos is enabled but trying to login using ldap authentication. i am able to connect through impala-shell and toad for hadoop tool.