Support Questions
Find answers, ask questions, and share your expertise

Impala and Cognos

New Contributor

Hi

 

I have problem running SQL quires from Cognos 11 to impala. I can see the SQL generated in Cognos contain the catalog name, the shema name and the table name in the FROM part in SQL.

 

Like this

 

select *

from impala.default.mytable.

 

Whan I run the sql in HUE I get an error, but after removing the catalogname(impala.) the SQL runs fine. I run on the lastes jdbc driver 2.5.31 and the cloudera 5.7 demo image. Any tips on how to make cognos remove the catalogname or accept the catalogname in the SQL?

 

Here is my connection string in Cognos :

;LOCAL;JDBC;URL=jdbc:impala://192.168.1.182:21050;DRIVER_NAME=com.cloudera.impala.jdbc41.Driver;

 

I have also tried this, but same error:

 

;LOCAL;JDBC;URL=jdbc:impala://192.168.1.182:21050/default;DRIVER_NAME=com.cloudera.impala.jdbc4.Driver;ibmcognos.subcode=CLOUDERA;

 

Untitled.png

 

 

 

Br

Petter Huseby

Affecto Norway.

2 REPLIES 2

Re: Impala and Cognos

New Contributor

It seems that fact quires are working :

 

SELECT SUM(ALL `M1_sample_08`.`total_emp`) as `C0` FROM `default`.`sample_08` `M1_sample_08`

 

But not dimensions

 

SELECT `M1_sample_08`.`code` AS `C0` FROM `Impala`.`default`.`sample_08` `M1_sample_08` GROUP BY `M1_sample_08`.`code` ORDER BY `M1_sample_08`.`code` ASC NULLS LAST

 

even on the same table.

 

 

 

Re: Impala and Cognos

New Contributor

It is a defect in the Simba devloped driver which is supposed to be addressed in the next (post 2.5.32) driver update. 

Get Cloudera suppor to confirm what the ETA is for the drive to be released.

Persons using Framework Manager can go into the data source object in the FM UI and remove the catalog name "Impala" which the Simba driver returns via the various DatabaseMetadata methods to describe tables, columns etc.