Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala process all reported as bad health

Impala process all reported as bad health

New Contributor

With Cloudera Manager 5.5.2 installed via RPM along will all other Hadoop packages, including Impala, all at 5.5.2, so there's no version mismatch, on CentOS 6.7, everythign seems to work except that CM shows all 3 Impala processes as "1 Bad Health/Web Server Status". The Impala process's web UIs work, as does everything I've tried in Impala itself (create table, insert, select, ...).

 

It appears that CM is using the wrong URL to get metrics. For example, connecting to http://hostname:25020/jsonmetrics yields "Could not open template: /usr/lib/impala//www//legacy-metrics.tmpl", which would correspond with the "org.codehaus.jackson.JsonParseException: Unexpected character ('C' (code 67)): expected a valid value" log entries. The same URL with ?json appended returns JSON.

 

Has anyone else seen this, not in the context of an upgrade or I18N issues? Since other threads have reported a similar problem due to language settings, I have tried setting LC_ALL to both C and en_US.UTF8, restarting/rebooting, with no impact. Is there some way to find out what URL CM is using to query Impala, and if so change it?