Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala queries through impala JDBC is running with empty user

Solved Go to solution
Highlighted

Re: Impala queries through impala JDBC is running with empty user

Rising Star

Interestingly, though many people in this thread are complaining of the same issue, no one has posted an error message that shows the correct syntax as outlined by the manual in the link from @Lars Volker.

 

Specifically, the manual shows the syntax for the connection string with a username (and no password) should be using AuthMech=2:

 

jdbc:impala://node1.example.com:21050;AuthMech=2;UID=impala

At least for me, this "resolved" the issue because now I am trying to debug a connection timeout.  So I guess that is progress :/

Re: Impala queries through impala JDBC is running with empty user

Super Collaborator

@epowell Apologize me, it's my fault since i solved it using auth mechanism 6 and didn't update the thread.

Re: Impala queries through impala JDBC is running with empty user

Rising Star

AuthMech=6?  I don't see that in the manual as an option.  Can you please post your full connection string?  Thanks

Re: Impala queries through impala JDBC is running with empty user

Super Collaborator

@epowell My bad, i mixed this with my issue with the impala ODBC.

 

In this issue i still unable to get it works.

 

Yes i'm passing the conf than Lars share but my issue with i change the AuthMech to 2, my queries stuck.

 

 jdbc:impala://node1.example.com:21050;AuthMech=2; UID=fawzea
 
Screen Shot 2018-10-21 at 5.17.19 PM.png
 
 
Log:
 
ERROR [2018-10-21 10:16:20,388] ({pool-2-thread-2} JDBCInterpreter.java[open]:197) - zeppelin will be ignored. driver.zeppelin and zeppelin.url is mandatory.

Re: Impala queries through impala JDBC is running with empty user

Rising Star

I cannot get it to work either.  I am trying to use the connection string within the DBbeaver database client and it just hangs forever.

Re: Impala queries through impala JDBC is running with empty user

Explorer

I am also  trying  DBbeaver

Re: Impala queries through impala JDBC is running with empty user

Rising Star

It seems like this thread still has no resolution.  I was inclined to give the benefit of the doubt to Cloudera and assume this was a DBeaver issue but it seems other people using straight Java cannot get a working connection string either. 

 

It would be great if we could get a cloudera employee to have another look at this thread.  In particular, Dbeaver is an outstanding DB client and I was using it with great success before I started using authentication.  It is a real shame to have lost it.

 

Can anyone successfully use the connection string from the manual (username, no password)?

Re: Impala queries through impala JDBC is running with empty user

New Contributor

Alright!

 

I can do Impala jdbc connect with passing username. When I connect with out user name, user name is shown as blank.

Re: Impala queries through impala JDBC is running with empty user

Rising Star
Can you post you connection string?

Re: Impala queries through impala JDBC is running with empty user

New Contributor

HOST=<<host>>; PORT=21050

Don't have an account?
Coming from Hortonworks? Activate your account here