Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Import Sqoop column names issue Nifi

Highlighted

Import Sqoop column names issue Nifi

New Contributor

Hi experts,

 

I have a question on Kylo and Nifi. The version of Kylo used is 0.10.1 The version of Nifi used is 1.6.0

 

When we create a feed for database ingest (using database as source), in the Additional Options step there is no provision to enter the source table column names.

However, in Nifi side, we use ImportSqoop processor which has a mandatory property field called Source Fields and it requires that the columns be entered, separated by commas. If it is not done, we get an error:

 

ERROR tool.ImportTool: Imported Failed: We found column without column name. Please verify that you've entered all column names in your query if using free form query import (consider adding clause AS if you're using column transformation)

 

As a work around, we are manually entering the column names in ImportSqoop processor's Source Fields property. But we want it to be directly available from Kylo UI.

 

For our requirement, we want ImportSqoop processor to take all the columns from the table automatically into this property without manual intervention at Nifi level. Is there any option to include all columns of a database table in the background automatically? Or is there any other possibility of giving this value in UpdateAttribute processor?

Don't have an account?
Coming from Hortonworks? Activate your account here