Support Questions
Find answers, ask questions, and share your expertise

Initial Installation of Cloudera Manager 5.14 stopped responding. Now can't reinstall.

Initial Installation of Cloudera Manager 5.14 stopped responding. Now can't reinstall.

New Contributor

I ran the following commands to install.

 

$ wget http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin

$ chmod u+x cloudera-manager-installer.bin

$ sudo ./cloudera-manager-installer.bin

 

When it was at the jdk stage it stopped responding.
So I closed the task.

Now when I try reinstalling it shows :
 

FATAL ERROR

Cloudera Manager 5 is already installed. Please uninstall it (by running /usr/share/cmf/uninstall-cloudera-manager.sh) before attempting to install it again. 

And a window that says Incomplete Installation : We will revert the changes that we made.

 

I tried running the uninstall-cloudera-manager.sh script on my terminal.
It gives ./uninstall-cloudera-manager.sh: 2: exec: ./.mojosetup/mojosetup: not found.

 

How do I remove the partially installed Cloudera 5.14 and reinstall.

I am a noob in this field.
A little help would be appretiated.

 

 

 

1 REPLY 1

Re: Initial Installation of Cloudera Manager 5.14 stopped responding. Now can't reinstall.

Super Guru

@Paperclip,

 

Sorry you hit some trouble on your first time playing.

I checked the code and it appears that a check is done to see if the uninstall-cloudera-manager.sh file exists.  If it does, it asks you to run the uninstaller.

 

It is hard to tell how far the install got or what happened, but perhaps you should review the log first.  I think there should be a series of log files that show activity for each stage of the install and that may help you understand how far it got and why it failed.  I can't recall where those logs are, off-hand.

 

If you are still stuck or cannot find logs, you could try renaming the /usr/share/cmf/uninstall-cloudera-manager.sh file /usr/share/cmf/uninstall-cloudrea-manager.sh-bad and then try running the installer again.

 

Note that if there was a problem installing JDK, make sure you have a connection to the internet as the installer will need to download packages to install.