Support Questions
Find answers, ask questions, and share your expertise

Install Hue on Ubuntu 14.04

Highlighted

Install Hue on Ubuntu 14.04

Hi All,

I have installed Hue on Ubuntu 14.04. Also Enabled High Availability.

Problem is when ever i restart the cluster the namenode address changing.

Please help me with the below properties for HA

fs_defaultfs , webhdfs_url, resourcemanager_host, resourcemanager_api_url etc.

Regards,

Vijay

8 REPLIES 8
Highlighted

Re: Install Hue on Ubuntu 14.04

@Vijay Kumar J

The properties should point to the hostname(and not IP) of the machines on which the respective services are deployed.

Are those cloud instances on which the cluster is setup?

Highlighted

Re: Install Hue on Ubuntu 14.04

@Sagar Shimpi

Actually these are physical VM's.

Highlighted

Re: Install Hue on Ubuntu 14.04

@Vijay Kumar

You could follow @Sagar Shimpi recommendation, however, quite often, virtual IP is used on HA load balancing scenarios. More than that almost any node in the cluster should have a static IP address, especially Master Nodes like NN. If your cluster is in a cloud like AWS, you should use Elastic IP for your key nodes. As a general practice, Master Nodes and permanent Data Nodes have static IP even in the cloud. The transient data nodes and other worker nodes that are only for computation operations don't need static IP. They are usually provisioned on task by task needs.

If any of the responses to your question addressed the problem don't forget to vote and accept he answer. If you fix the issue on your own, don't forget to post the answer to your own question. A moderator will review it and accept it.

Highlighted

Re: Install Hue on Ubuntu 14.04

@Constantin Stanca

The issue is not yet fixed. As they are physical VM's and have static Ip-address.

My only question is for which properties do i need to include HA Namenode address

Highlighted

Re: Install Hue on Ubuntu 14.04

@Vijay Kumar J

You state that the problem "Problem is when ever i restart the cluster the namenode address changing". On the other hand you state that those are physical VMs (you probably mean VM on on-prem infrastructure) and have static IP addresses. What namenode address is changing? Could be more specific? We need to nail the problem description before talking about those properties.

Highlighted

Re: Install Hue on Ubuntu 14.04

@Constantin Stanca

Sorry For the late reply.

I am sorry if u didn't understand the question.

My question is : If i restart the cluster using Ambari, complete cluster and services gets restarted. Once the HDP cluster gets in running state previous namenode address gets changed.

i.e : http://xxx.com:50070 gets changed to

http:// yyy.com:50070

But they both are in HA. if these address keeps on changing the i guess i need to change HUE parameters.

Highlighted

Re: Install Hue on Ubuntu 14.04

@Vijay Kumar J

I don't understand your setup that will lead to a hostname change. In your case you are not even restarting the infrastructure, just HDP.

The only time I've seen the hostname changing is when you use a cloud provider like AWS and you don't use static IP for your server nodes or at least for your edge nodes and that is a bad practice anyway, but again that is if you start the servers, not the HDP. It just does not make sense a setup in which host names are changing on restart of HDP. Even if you had to spin off a cluster in AWS for some intensive computation you should still keep one edge node for your Hue and etc. and a configuration file that is capable to adapt to hostname and ip addresses change.

I am still trying to figure out how HDP restart could possibly change your NN hostname...

Re: Install Hue on Ubuntu 14.04

Contributor

Hi Vijay Kumar J

If your hdfs is HA enabled then you need to do below config changes in hue.ini

fs_defaultfs=<hdfs nameservice>

httpfs is needed to support a centralized WebHDFS interface to an HA enable NN Cluster

for that follow below link

https://community.hortonworks.com/articles/804/httpfs-configure-and-run-with-hdp-224x.html

and in hue.ini put webhdfs_url=http://<your httpfs host>:14000/webhdfs/v1/

and in resourcemanager_host=<your resource manger host>

Please accept this answer if it answers your question.