Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Install R on HDP 2.6 cluster

Solved Go to solution
Highlighted

Install R on HDP 2.6 cluster

I try to install R on worker nodes in HDP 2.6 cluster on centos 7.

Running:

$ yum install R-devel libcurl-devel openssl-devel

I am getting

...
Error: Package: R-core-devel-3.2.3-4.el7.x86_64 (HDP-UTILS-1.1.0.21)
           Requires: tre-devel
Error: Package: R-core-3.2.3-4.el7.x86_64 (HDP-UTILS-1.1.0.21)
           Requires: libtre.so.5()(64bit)
...

Any pointers here much appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Install R on HDP 2.6 cluster

Super Collaborator
@Daniel Kozlowski

Install EPEL repo and try the installation again. Required dependencies for R-devel are available in epel repo.

# yum install -y epel-release

#yum install R-devel libcurl-devel openssl-devel

Note that you need internet connectivity to allow connection for epel repo.

View solution in original post

5 REPLIES 5

Re: Install R on HDP 2.6 cluster

@Daniel Kozlowski

Does installing those libraries e.g. yum install libtre-devel tre-devel help with matching the prerequistes?

Highlighted

Re: Install R on HDP 2.6 cluster

@Ward Bekker

Thanks for your comment. I had already tried that but this did not help.

...
No package libtre-devel available.
No package tre-devel available.
...
Highlighted

Re: Install R on HDP 2.6 cluster

Super Collaborator
@Daniel Kozlowski

Install EPEL repo and try the installation again. Required dependencies for R-devel are available in epel repo.

# yum install -y epel-release

#yum install R-devel libcurl-devel openssl-devel

Note that you need internet connectivity to allow connection for epel repo.

View solution in original post

Highlighted

Re: Install R on HDP 2.6 cluster

@rguruvannagari

Thanks - that works.

Highlighted

Re: Install R on HDP 2.6 cluster

Expert Contributor

Worked for me once I installed the correct version of epel

If that doesn't work for you and you get: (check that epel install centos7 and not centos6)


Error: Package: R-core-3.4.1-1.el6.x86_64 (epel) Requires: libicui18n.so.42()(64bit) Error: Package: R-core-3.4.1-1.el6.x86_64 (epel) Requires: libicuuc.so.42()(64bit) Error: Package: qpdf-libs-5.1.1-5.el6.x86_64 (epel) Requires: libpcre.so.0()(64bit)

FYI to fix this you can just edit the repo file to point to 7 instead of 6 (and fix the gpg check)

Don't have an account?
Coming from Hortonworks? Activate your account here