Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Installation HDF on HDP

avatar
Rising Star

we are having HDP 2.6.2 running properly. We are looking to install nifi in our environment.

Is it recommended to install HDF on existing HDP?

Have there any HDF version compatibility with HDP 2.6.2?

1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
6 REPLIES 6

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Rising Star

@Rajendra Manjunath

While installing HDF in HDP, i got below error:

Caused by: org.xml.sax.SAXParseException; systemId: file:/var/lib/ambari-server/resources/stacks/HDF/3.1/upgrades/nonrolling-upgrade-3.1.xml; lineNumber: 213; columnNumber: 94; cvc-complex-type.3.2.2: Attribute 'supports-patch' is not allowed to appear in element 'task'

avatar
Expert Contributor

@Vinay K

Which version of Ambari you are using?

And are you using mpack?

avatar
Rising Star

@Rajendra Manjunath

I'm using Ambari 2.5.2 version.

And im using mpack.

avatar
Expert Contributor

HDF 3.1.X stack works with Ambari 2.6.1 and higher.

Please read the support metric of the HDF stack your are using.

avatar
Rising Star

@Rajendra Manjunath

i have installed HDF 3.0.3, which has installed properly using CLI.

Now i'm stuck on install on.. in ambari. In HDF cluster name is none. while i click on Install on.. then click on Test_cluster, we directly redirected to HDP installed component. HDF is not available in installed component.

73412-hdf-screenshot.png