Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Installation of Storm 3.1 Fails because Slider 3.1 not found.

Installation of Storm 3.1 Fails because Slider 3.1 not found.

Explorer

While enabling kerberos on Ambari managed hadoop cluster we faced error at the last stage, when services are started. It failed at Slider Install step, with the following error.

2018-06-05 16:17:28,171 - Execution of '/usr/bin/yum -d 0 -e 0 -y install storm_3_1_0_0_564-slider-client' returned 1. Error: Package: storm_3_1_0_0_564-slider-client-1.1.1.3.1.0.0-564.x86_64 (HDF-3.0-repo-1)

Requires: slider_3_1_0_0_564

Existing version of slider and storm

]$ sudo yum list | grep storm
storm_2_6_3_0_235-slider-client.x86_64  1.1.0.2.6.3.0-235        @HDP-2.6-repo-1
atlas-metadata-storm-plugin.noarch      0.8.0.2.6.3.0-235        HDP-2.6-repo-1
atlas-metadata_2_6_3_0_235-storm-plugin.noarch
ranger-storm-plugin.noarch              0.7.0.3.1.0.0-564        HDF-3.0-repo-1
ranger_2_6_3_0_235-storm-plugin.x86_64  0.7.0.2.6.3.0-235        HDP-2.6-repo-1
ranger_3_1_0_0_564-storm-plugin.x86_64  0.7.0.3.1.0.0-564        HDF-3.0-repo-1
storm.noarch                            1.1.1.3.1.0.0-564        HDF-3.0-repo-1
storm-slider-client.noarch              1.1.1.3.1.0.0-564        HDF-3.0-repo-1
storm_2_6_3_0_235.x86_64                1.1.0.2.6.3.0-235        HDP-2.6-repo-1
storm_3_1_0_0_564.x86_64                1.1.1.3.1.0.0-564        HDF-3.0-repo-1
storm_3_1_0_0_564-slider-client.x86_64  1.1.1.3.1.0.0-564        HDF-3.0-repo-1
]$ sudo yum list | grep slider
slider_2_6_3_0_235.noarch               0.92.0.2.6.3.0-235       @HDP-2.6-repo-1
storm_2_6_3_0_235-slider-client.x86_64  1.1.0.2.6.3.0-235        @HDP-2.6-repo-1
slider.noarch                           0.92.0.2.6.3.0-235       HDP-2.6-repo-1
storm-slider-client.noarch              1.1.1.3.1.0.0-564        HDF-3.0-repo-1
storm_3_1_0_0_564-slider-client.x86_64  1.1.1.3.1.0.0-564        HDF-3.0-repo-1

There doesn't seem to be a slider rpm available with HDF repo binaries.

1. Is it possible to skip the upgrade of Storm via HDF repo ?

1 REPLY 1
Highlighted

Re: Installation of Storm 3.1 Fails because Slider 3.1 not found.

Cloudera Employee

@Bhanu Pamu

It seems this is because of the Bug (https://issues.apache.org/jira/browse/AMBARI-22290). You can disable the HDF repository to workaround this issue simply.

Don't have an account?
Coming from Hortonworks? Activate your account here