Support Questions
Find answers, ask questions, and share your expertise

Installation under RHEL 7.3 has some versioning issues

Explorer

I try to install Ambari-server under RedHat 7.3, python 2.7.5

I got the following Ambari and HDP repositories and ran `yum clean all` just to be sure:

http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.5.2.0/ambari.repo

http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.6.2.0/hdp.repo

After I run yum `install ambari-server` i try to setup it using `ambari-server setup` and I am getting the following issue:

Traceback (most recent call last):
File "/usr/sbin/ambari-server.py", line 40, in <module>
from ambari_server.serverUpgrade import upgrade, upgrade_stack, set_current
File "/usr/lib/python2.6/site-packages/ambari_server/serverUpgrade.py", line 51, in <module>
from ambari_server.setupMpacks import replay_mpack_logs
File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 30, in <module>
from ambari_commons.inet_utils import download_file, download_file_anyway
ImportError: cannot import name download_file_anyway

It is weird to me that the ambari-server packages are installed under python2.6 (which is not installed) since the RHEL7 version should work with python2.7.

What is the issue? how can it be solved?

1 ACCEPTED SOLUTION

Accepted Solutions

Super Mentor

@ A P

Looks like the problem is that you have installed "ambari-server" but not the ambari-agent.

So can you please try the following and see if it works:

1. Reinstall ambari-server

# yum reinstall ambari-server -y

2. Install ambari-agent

# yum install ambari-agent -y

3. Now try to run the ambari-server setup

# ambari-server setup

.

View solution in original post

2 REPLIES 2

Super Mentor

@ A P

Looks like the problem is that you have installed "ambari-server" but not the ambari-agent.

So can you please try the following and see if it works:

1. Reinstall ambari-server

# yum reinstall ambari-server -y

2. Install ambari-agent

# yum install ambari-agent -y

3. Now try to run the ambari-server setup

# ambari-server setup

.

View solution in original post

Explorer

Thank you for the quick and accurate response! this solved the issue.