Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Installing Ambari and HDP for Debian 8.

Highlighted

Installing Ambari and HDP for Debian 8.

Hi, I'm trying to make ambari work for debian 8. I want to know how the HDP stack and the repository info's are mapped and how this data is populated? I'm able to get past the registration process by adding the entry in os_family.json. But during the deployment process. The error gets thrown again. I wanted to know how the data is populated which maps the repository version and the OS version.

Thanks,

Sriganesh

18 REPLIES 18
Highlighted

Re: Installing Ambari and HDP for Debian 8.

@Sriganesh Navaneethakrishnan

Debian is not listed in supported OS. I highly recommend to stick with the OS listed in the following doc

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_Installing_HDP_AMB/content/_operating_sys...

Highlighted

Re: Installing Ambari and HDP for Debian 8.

@Neeraj Sabharwal Thank you so much. I know the requirements. I'm trying to make it more work for Debian 8. I want to know how the initialization is works. I have dug down to find that there is a unmodifiable map that is created that maps the HDP repositories with the compatible OS. I want to know, how this information is populated. I think its just a matter of configuration to make is work in debian 8. This is mainly because of the dependencies for HDP and Ambari with debian 7 are similar with debian 8

Highlighted

Re: Installing Ambari and HDP for Debian 8.

@Sriganesh Navaneethakrishnan What will happen when you end up hitting other package related or unknown issues because of the mismatch of OS and bits?

I am sure that we/you can fix the hack/tweak to make this work

https://github.com/apache/ambari

You can search the details in the above code.

Highlighted

Re: Installing Ambari and HDP for Debian 8.

Exactly. I understand. But I want to try it. There is not much changes in the existing libraries with respect to debian 7 and debian 8, there is minimal changes to existing libraries and addition of a few more enhancements. As far as I can see, the HDP installation shouldn't break for debian 8, except for this small OS Check. Hence my curiosity. Its just an experiment that I'm trying. I'm looking into that repository. Thank you for pointing out.

Highlighted

Re: Installing Ambari and HDP for Debian 8.

Highlighted

Re: Installing Ambari and HDP for Debian 8.

Mentor

@Sriganesh Navaneethakrishnan I guess you realize that you're breaking warranty by doing so, that said, take a look at solution here, disable one script and see if you can register your host https://community.hortonworks.com/questions/4324/hdp-support-for-mix-of-os-releases-within-a-cluste....

Highlighted

Re: Installing Ambari and HDP for Debian 8.

Thanks @Artem Ervits. I did the same and was able to register the host properly. But deployment of the components is the place that I'm stuck with. It seems, the OS compatibility check [mapping process] is done in two locations.

I'll show you the logs... WARN [qtp-ambari-client-21] ClustersImpl:552 - Trying to map host to cluster where stack does not support host's os type, clusterName=sample1, clusterStackId=HDP-2.3, hostname=xxx, hostOsFamily=debian8

29 Feb 2016 16:04:00,418 ERROR [qtp-ambari-client-21] AbstractResourceProvider:280 - Caught AmbariException when creating a resource

org.apache.ambari.server.AmbariException: Trying to map host to cluster where stack does not support host's os type, clusterName=sample1, clusterStackId=HDP-2.3, hostname=xxx, hostOsFamily=debian8

Highlighted

Re: Installing Ambari and HDP for Debian 8.

Mentor

@Sriganesh Navaneethakrishnan consider creating your own stack https://cwiki.apache.org/confluence/display/AMBARI/Stacks+and+Services build packages from source and deploy using Ambari. Have you looked at Apache Bigtop, it might be something you could use http://bigtop.apache.org/

Re: Installing Ambari and HDP for Debian 8.

This is something, I didn't look at. This makes more sense to me. Let me take a look. Thanks again. @Artem Ervits

Don't have an account?
Coming from Hortonworks? Activate your account here