I'm trying to install the above on Ubuntu 12.04LTS
3.2.0-56-generic #86-Ubuntu SMP Wed Oct 23 09:20:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
The entire installation fails on the agent part with the following message:
The following packages have unmet dependencies: cloudera-manager-agent : Depends: libsasl2-modules-gssapi-mit but it is not going to be installed E: Unable to correct problems, you have held broken packages. END (100) remote package cloudera-manager-agent could not be installed, giving up waiting for rollback request
Trying to install libasl2-modules-gssapi-mit replies with the following:
sudo apt-get install libsasl2-modules-gssapi-mit Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help resolve the situation: The following packages have unmet dependencies: libsasl2-modules-gssapi-mit : Depends: libsasl2-modules (= 2.1.25.dfsg1-3) but 2.1.25.dfsg1-3ubuntu0.1 is to be installed E: Unable to correct problems, you have held broken packages.
And when attempting to install libsasl2-modules the latest package is there.
sudo apt-get install libsasl2-modules Reading package lists... Done Building dependency tree Reading state information... Done libsasl2-modules is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
apt-get check returns nothing
sudo apt-get check Reading package lists... Done Building dependency tree Reading state information... Done
apt-get -f install returns nothing either.
Any idea how could this be fixed?
I'm guessing you've tried again since you posted this message, but this appears to have been caused by a transient error in the Ubuntu package archive. You had a newer version of libsasl2-modules installed and it was unaware of a matching version of libsasl2-modules-gssapi-mit. I've checked the Ubuntu package list and the new version does exist.
I notice you never say that you did an apt-get update - you should always do that in these situations to esnure the latest package list is downloaded.
Unset the following two option on System Software Sources->Updates tab.
Unset Pre-released updates(precise-proposed)
Unset Unsupoorted updates(precise-backports)
And then, try to update software source again.
Install it again at the last.
This is my steps.
Did any one fix this I get the same error on Ubuntu 14.04 LTS when I install the Cloudera Hadoop install using Cloudera Manager. Please could some one help?