Support Questions
Find answers, ask questions, and share your expertise

Installing CDH5 on EC2 Linux

New Contributor

Hi All,

I am trying to install CDH Manager(Cloudera-manager-install.bin) on AWS EC2 m3.large instance, with Linux 6.5. However I get SeLinux is enabled error and the installation exits.

I tried to change the SeLinux setting by using

1.sudo setenforce 0(@root)

2.    Reboot instance

3.    Run the ./cloudera-manager-install bin

 

I still get the SeLinux enabled error. I am not able to edit /etc/selinux/config(Permission denied). Any suggestions or work arounds. Apreciate your guidance and advise.

 

Thank you

Ranjit

 

2 REPLIES 2

Expert Contributor

The process you followed disables selinux temporarily.....Please follow the below steps to disable it...

 

Disabling SELinux

Sometimes when you are not well acquainted with SELinux functionalities, it is better to disable it. We can not disable the SELinux without a reboot. An alternative option would be – to set SELinux in Permissive mode. To completely disable SELinux edit the configuration file /etc/sysconfig/selinux or the /etc/selinux/config which is a soft link to /etc/sysconfig/selinux file.

# ls -l /etc/sysconfig/selinux
lrwxrwxrwx. 1 root root 17 Mar  2 13:03 /etc/sysconfig/selinux -> ../selinux/config
# cat /etc/sysconfig/selinux

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

Edit this file and take a reboot of the system for the changes to take effect.

Em Jay

New Contributor

Thanks for your reposnse.

I did try to edit the config file. But in EC2 instance(I log into via Putty) when I do  /etc/selinux/config , I get Permission Denied error. I did sudo su to get to the root@ of the instance. But still I get the permission error. I am not sure how to edit this config file on EC2. Also I read if the instance is clean then the SeLinux should not be enabled, I guess AWS by default enables on their images(for security purposes).

 

--Ranjit