Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Installing HDP Package Failed for HDP-2.5.3

Installing HDP Package Failed for HDP-2.5.3

Contributor

Hi,

We have upgraded ambari from ambari-2.5.2 to Ambari-2.6.2.

We are trying to upgrade HDP from HDP-2.3.4.0 to HDP-2.5.3. In "Installing package" section we are getting following error:

2018-05-21 06:06:29,085 - Attempting to determine actual version with build number.
2018-05-21 06:06:29,085 - Old versions: ['2.3.4.0-3485']
2018-05-21 06:06:29,085 - call[('ambari-python-wrap', u'/usr/bin/hdp-select', 'versions')] {}
2018-05-21 06:06:29,110 - call returned (0, '2.3.4.0-3485')
2018-05-21 06:06:29,111 - New versions: ['2.3.4.0-3485']
2018-05-21 06:06:29,111 - Deltas: set([])
2018-05-21 06:06:29,111 - Cannot determine actual version installed by checking the delta between versions before and after installing package
2018-05-21 06:06:29,111 - Will try to find for the actual version by searching for best possible match in the list of versions installed
2018-05-21 06:06:29,111 - Failure while computing actual version. Error: Could not determine actual version installed. Try reinstalling packages again.
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 458, in install_packages
    self.compute_actual_version()
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 301, in compute_actual_version
    raise Fail(msg)
Fail: Could not determine actual version installed. Try reinstalling packages again.


Command failed after 1 tries

Previously we have downgraded HDP-2.5.3 to HDP-2.3.4. After downgrading we have deleted 2.5.3.0-37 directory under /usr/hdp.

Now, we again want to upgrade to HDP-2.5.3. But this time we are getting above error on nodes.

How to resolve it? Please suggest.

Thanks in advance.