Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Internet Explorer always using NTLM instead of Kerberos

Highlighted

Internet Explorer always using NTLM instead of Kerberos

New Contributor

I am trying to browse my HDFS system from internet explorer but for some reason it is always using NTLM instead of Kerberos, so I receive the message

GSSException: Defective token detected (Mechanism level: GSSHeader did not find the right tag)

If I browse from Firefox (after setting the properties network.auth.use-sspi=false and network.negotiate-auth.trusted-uris=https://pd-vrt-21488) everything works fine. In IE I added https://pd-vrt-21488:50470 to the list of local intranet sites and enabled “Integrated Windows Authentication”.

Looking at the request by using Fiddler I see the difference between Firefox using Kerberos and IE using NTLM.

Firefox header:

Authorization: Negotiate YIICyAYGKwYB .....much more character.....V2HbPG57vXnQ7Vm7ba7MTJ7qzJ7zA7+1foY=

IE header:

Authorization: Negotiate TlRMTVNTUAABAAAAl4II4gAAAAAAAAAAAAAAAAAAAAAGAbEdAAAADw==

Any ideas what’s wrong ?

2 REPLIES 2
Highlighted

Re: Internet Explorer always using NTLM instead of Kerberos

@Johan Klijn

I hope this link help for you link

Highlighted

Re: Internet Explorer always using NTLM instead of Kerberos

New Contributor

@Divakar Annapureddy, I already found this page and tried the sugestions, but unfortunately it did not solve the issue.

Don't have an account?
Coming from Hortonworks? Activate your account here