Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Is CDH required for Oryx 2 ?

Is CDH required for Oryx 2 ?

New Contributor

Sean,

 

 Is CDH required for Oryx 2 ?

 

According to matrix summary, it seems required (along with Kafka parcel). But, the top of the page not indicates CDH (but it lists Hadoop 2.7.0 and Kafka 0.10.2...).

http://oryx.io/docs/admin.html

 

Can I just use Hadoop and Kafka (not Cloudera Kafka parcel) ?

 

Thanks

1 REPLY 1

Re: Is CDH required for Oryx 2 ?

Master Collaborator

It's not required. Nothing about uses anything that would be particular to CDH. It uses APIs in a pretty simple way.

 

 

Given limited time, I only test on CDH, and make the versions fit the combinations of component versions that appear in CDH releases.


However if you got similar versions of these components to work together independently, I don't know of any reason it wouldn't work.


You're most likely to run into version problems with Kafka.