Support Questions

Find answers, ask questions, and share your expertise

Is HDP 3.1.0 works with Oracle JDK 12 ? Any experiences ?

Though it supports Oracle JDK 8 officially, will HDP 3.1.0 works with Oracle JDK 12 ? Any experiences?

Appreciate your feedback.

2 REPLIES 2

@Murali Meesala ,

Ideally ask per https://supportmatrix.hortonworks.com , JDK 12 is not supposed to be used for HDP-3.1.0 as Hortonworks Certification team has not certified to use it .

Its best to be in JDK 8 or you may run into unforeseen issues.

as Oracle JDK 8 is ending support you can see if you can migrate to Open JDK 1.8

The above question and the entire response thread below were originally posted in the Community Help track. On Fri Jul 19 05:29 UTC 2019, a member of the HCC moderation staff moved it to the Hadoop Core track. The Community Help Track is intended for questions about using the HCC site itself.

Bill Brooks, Community Moderator
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.