Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Is ambari 2.5.0.3 fit for upgrade to 2.7?

Highlighted

Is ambari 2.5.0.3 fit for upgrade to 2.7?

New Contributor

For a test case, we have a 3 node cluster installed with HDP-2.6.0.3 and Ambari Version 2.5.0.3. We need to upgrade this cluster specifically to HDP 3.0.1 and ambari 2.7. We've followed the instructions in the hortonworks documents fo the letter but we keep getting the following error for "ambari-server upgrade"

INFO: about to run command: /usr/jdk64/jdk1.8.0_112/bin/java -cp '/etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/postgresql-jdbc.jar' org.apache.ambari.server.upgrade.SchemaUpgradeHelper > /var/log/ambari-server/ambari-server.out 2>&1 INFO: process_pid=11839 Traceback (most recent call last): File "/usr/sbin/ambari-server.py", line 1060, in mainBody() File "/usr/sbin/ambari-server.py", line 1030, in mainBody main(options, args, parser) File "/usr/sbin/ambari-server.py", line 980, in main action_obj.execute() File "/usr/sbin/ambari-server.py", line 77, in execute self.fn(*self.args, **self.kwargs) File "/usr/lib/ambari-server/lib/ambari_server/serverUpgrade.py", line 262, in upgrade retcode = run_schema_upgrade(args) File "/usr/lib/ambari-server/lib/ambari_server/serverUpgrade.py", line 162, in run_schema_upgrade upgrade_response = json.loads(stdout) File "/usr/lib/ambari-server/lib/ambari_simplejson/__init__.py", line 307, in loads return _default_decoder.decode(s) File "/usr/lib/ambari-server/lib/ambari_simplejson/decoder.py", line 335, in decode obj, end = self.raw_decode(s, idx=_w(s, 0).end()) File "/usr/lib/ambari-server/lib/ambari_simplejson/decoder.py", line 353, in raw_decode raise ValueError("No JSON object could be decoded") ValueError: No JSON object could be decoded

/var/log/ambari-server/ambari-server.log shows the following

2019-05-21 15:13:19,589  INFO [main] SchemaUpgradeHelper:426 - Upgrading schema to target version = 2.7.3.02019-05-21 15:13:19,595  INFO [main] SchemaUpgradeHelper:435 - Upgrading schema from source version = 2.5.02019-05-21 15:13:19,598 ERROR [main] SchemaUpgradeHelper:475 - Exception occurred during upgrade, failedorg.apache.ambari.server.AmbariException: Database version does not meet minimal upgrade requirements. Expected version should be not less than 2.5.1, current version is 2.5.0    at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:440)

If someone could point me to the right way to solving this problem, I would be very thankful.