Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Is there any way to disable "kill application" button to Resource Manager's Web UI ?

avatar
Guru

Hello Friends,

Is there any way to disable "kill application" button to Resource Manager's Web UI ?

Thanks in advance.

1 ACCEPTED SOLUTION

avatar
Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
8 REPLIES 8

avatar

@Saurabh Kumar

Good question. I don't think there is a way to disable the "kill application" button.

Perhaps if a user is granted read only permission to the Dashboard in Ambari -> Manage Ambari, he might be unable to do so, but I also see that even a read only user can access the RM UI. So the only way is to not give that user any permission to the dashboard or to the RM UI via Knox secured by Ranger.

Perhaps someone else has a better answer.

avatar
Master Guru

I think there are different options.

You can enable HTTP authentication using SPNEGO and kerberos for the web uis

https://hadoop.apache.org/docs/current/hadoop-project-dist/hadoop-common/HttpAuthentication.html

( Problem is that Spnego is a bit finicky since the computers running the web browser need to be in the kerberos realm )

And you can disable administration of queues for specific users and groups. I.e. only allow a specific subgroup of users to kill applications.

https://hadoop.apache.org/docs/r2.4.1/hadoop-yarn/hadoop-yarn-site/CapacityScheduler.html#Configurat...

Is your cluster kerberized?

avatar

avatar
Guru

Hi Benjamin,

Thanks for your reply. And no we do not have kerbaros in our cluster. We are just using knox and ranger.

avatar
Master Guru

In that case you cannot use SPNEGO. But you might be able to stop users from administering queues. (killing applications ). I have seen these settings not working on a non-kerberized cluster but it might have been a bug.

avatar
Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Master Guru

That is cool, I didn't find it in the original JIRA patch weird.

avatar
Guru

@Ancil McBarnett @Benjamin Leonhardi @Jonas Straub: I have successfully disabled "kill Application" button by adding below property to yarn-site.xml.

yarn.resourcemanager.webapp.ui-actions.enabled= false.

For more detailed steps you can refer to below link .

http://www.hadoopadmin.co.in/bigdata/how-to-disable-kill-application-button-in-resource-manager-web-...