Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Issue while granting user permission in Hbase

Solved Go to solution
Highlighted

Issue while granting user permission in Hbase

Contributor

While granting user permission in HBase, it is failing with error. Recently we have de-kerberized and kerberized the Cluster.

"ERROR ArgumentError: DISABLED: Security features are not available"

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Issue while granting user permission in Hbase

Rising Star

@prsingh

That seems to be a bug, let's disable the ACL for ZK, by adding below in zookeeper-env.sh -Dzookeeper.skipACL=yes

1) Stop HBase 
2) Add -Dzookeeper.skipACL=yes in zookeeper-env.sh
export SERVER_JVMFLAGS="$SERVER_JVMFLAGS -Dzookeeper.skipACL=yes -Djava.security.auth.login.config={{zk_server_jaas_file}}" 
3) rmr /hbase-secure/table/hbase:acl 
4)revert back the change in step 2 -Dzookeeper.skipACL=yes 
5) Restart HBase again 
6) Try grant it should work now
5 REPLIES 5

Re: Issue while granting user permission in Hbase

Rising Star

Hi @prsingh Are you able to create and list hbase tables? Also HBase UI is working fine? Can you also confirm if Ranger is enabled?

Re: Issue while granting user permission in Hbase

Contributor

@nyadav

Yes, I'm able to create and list table from shell. Only issue is while granting permission.

Also Ranger is not enabled.

Re: Issue while granting user permission in Hbase

Rising Star

Thanks. Let's remove the acl znode from the ZK. Stop HBase services, and follow below steps

--login to zkcli (hbase zkcli)
-- rmr /hbase-secure/table/hbase:acl

Re: Issue while granting user permission in Hbase

Contributor

@nyadav

I am getting below exception while running the below command,

rmr /hbase-secure/table/hbase:acl

Authentication is not valid : /hbase-secure/table/hbase:acl

Re: Issue while granting user permission in Hbase

Rising Star

@prsingh

That seems to be a bug, let's disable the ACL for ZK, by adding below in zookeeper-env.sh -Dzookeeper.skipACL=yes

1) Stop HBase 
2) Add -Dzookeeper.skipACL=yes in zookeeper-env.sh
export SERVER_JVMFLAGS="$SERVER_JVMFLAGS -Dzookeeper.skipACL=yes -Djava.security.auth.login.config={{zk_server_jaas_file}}" 
3) rmr /hbase-secure/table/hbase:acl 
4)revert back the change in step 2 -Dzookeeper.skipACL=yes 
5) Restart HBase again 
6) Try grant it should work now