Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Issue with flume-ng agent running

Highlighted

Issue with flume-ng agent running

New Contributor

Hi Everyone,

 

I am new to BigData and have gone through multiple online documents to learn flume.  I am Cloudera Express 5.13.0. 

 

As per my understanding flume service and flume agent are basically same thing. So, we can add flume service in cloudera manager or can run flume agent outside in command prompt as well.

 

When I run "which flume" , I get an answer no flume found.

When I run "which flume-ng", I get an answer as /usr/bin/flume-ng which mean cloudera quick start has flume-ng agent installed.

 

Now when I start flume-ng agent using command: 

sudo service flume-ng-agent start

the agent start and outcome of status command is ok but when I go to cloudera manager I do not see flume agent running there. Similarly after I stop "sudo service flume-ng-agent stop" in command prompt and when I start service/agent in cloudera manager then when I execute command "sudo service flume-ng-agent status" in command prompt the output is flume-ng not running. I am confused with this. Is flume-ng from command prompt not same as starting service in cloudera manager? Also, when I start flume-ng in command prompt I do not see logs rolling in "/var/log/flume-ng". Also, I do not see flume-ng service to add in cloudera manager but I see flume to add so I have added flume with all its default configuration. Please help.

Don't have an account?
Coming from Hortonworks? Activate your account here