Support Questions
Find answers, ask questions, and share your expertise

Japanese characters not shown in hive

Japanese characters not shown in hive

New Contributor

I have uploaded one file in hive with name column which has Japanese names. When I display the file on hive terminal, it shows me garbage value like 'Ã�ストラãƒ'. How can I get it to display me names in Japanese only? I am very new to hive and have not been able to find a solution.

1 REPLY 1

Re: Japanese characters not shown in hive

Hi @Shashank Chauhan

Are you using hive cli or beeline? or something else, like hive view in ambari? The solution is different depending on this.
If you are on cli/beeline, try setting the LANG env viariable before you run your query in beeline

export LANG=ja_JP.UTF-8

If you are using ambari views, you may have to add that into ambari-env.sh

Update: BTW you may also have to set the SERDEPROPERTIES for your table, if you havent already. Ex.

ALTER TABLE your_table SET SERDEPROPERTIES ('serialization.encoding'='SJIS');