Support Questions
Find answers, ask questions, and share your expertise

Jenkins is not working in HDP2.6

Jenkins is not working in HDP2.6

Explorer

Hi,

I am using HDP 2.6. I need to use Jenkins for continuous integration. I am unable to install correctly.

I followed below steps

1. sudo rpm --import http://pkg.jenkins-ci.org/redhat-stable/jenkins-ci.org.key

2. sudo yum install jenkins

3. sudo service jenkins start

4. iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT -m comment --comment "Tomcat Server port

5. service iptables save

from my windows desktop if I browse this jenkins URL, http://localhost:8080/, It is not opening. It launches ambari.

What am I doing wrong? Please assist.

7 REPLIES 7
Highlighted

Re: Jenkins is not working in HDP2.6

@elango vaithiyanathan,

Jenkins will by default run on port 8080. If you were using the default config , then the step 3 might have failed for you

You can check it by running

ps -ef | grep -i jenkins

I suggest you to change the port of jenkins and then restart jenkins. To change the port open "/etc/sysconfig/jenkins" and search for JENKINS_PORT. You should see that it is set to 8080. Change the port which doesn't conflict with other ports and restart the jenkins (ie run step 3).

Thanks,

Aditya

Highlighted

Re: Jenkins is not working in HDP2.6

Explorer

@Aditya ,

As you told, I followed the below steps. But still I can not access the jenkins from my windows desktop.

1. Modified the port number to 8081

2. Restarted the jenkins service

3. iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 8081 -j ACCEPT -m comment --comment "Tomcat Server port"

4. service iptables save

When I tried to access jenkins url- http://localhost:8081/, I am getting the below error message. Can you please look into this?

This site can’t be reached

localhost refused to connect.

Highlighted

Re: Jenkins is not working in HDP2.6

@elango vaithiyanathan,

Can you please check if jenkins is running. Can you give the output of below commands

ps -ef | grep -i jenkins<br>netstat -tupln | grep 8081

If the first command doesn't return any output. Then try changing to some random port 9099. I'm not really sure if port 8081 will be occupied by another process

Thanks,

Aditya

Highlighted

Re: Jenkins is not working in HDP2.6

Explorer

@ Aditya,

Please find below the screen shot of the commands output.

43416-jenkins.png

Highlighted

Re: Jenkins is not working in HDP2.6

@elango vaithiyanathan,

Looks like jenkins is running. Can you try with IP /hostname of the box instead of using localhost.

Highlighted

Re: Jenkins is not working in HDP2.6

Rising Star

In adittion, within my cluster, port was assigned to 9090, by getting the pid from above command I just ran

netstat -tuplen | grep <pid>

and I got the port where the UI is running

Highlighted

Re: Jenkins is not working in HDP2.6

Super Mentor

@elango vaithiyanathan

Looks like you are running HDP Sandbox which will using port 8080 (as Port Forwarding address) for AmbariServer.

So either you will need to stop the Ambari Server on your Sandbox and then try again.

.

Also many times the browser caches the Ambari UI scripts (cached data) so even if we hit loalhost:8080 it will show the cached pages (even if the ambari server ) is not running. So please try the incognito mode.

.

However In Virtual Box you have option to configure Network Port Forwarding to Add new ports (Like 8081 for your Jenkins)

Please see thePort Forwarding Section in the below link:

https://community.hortonworks.com/articles/65914/how-to-add-ports-to-the-hdp-25-virtualbox-sandbox.h...

Don't have an account?