Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Kafka access in HBase Coprocessor inside Kerberozied cluster

Kafka access in HBase Coprocessor inside Kerberozied cluster

Explorer

 

Kafka Access Inside HBase Co-processor code in Kerberoized Cluster

 

Versions

 

Cloudera : 5.11.1

Kafka: 0.10.1

HBase: 1.2.0

 

We are facing an issue for creating the Kafka producer instance inside the HBase coprocessor code inside a Kerberozied cluster.  Inside the code we already configure “java.security.auth.login.config” property using System.property. We observed that by default in hbase-env.sh having path /etc/hbase/conf have value export HBASE_OPTS="$HBASE_OPTS -Djava.security.auth.login.config=/etc/hbase/conf/jaas.conf" which is pointing to hbase jaas.conf.

To confirm about the file permission we tried to read the jaas.conf file from /etc/ path and it is working fine.

We are getting “Jaas configuration not found” exception during the execution.

Below are the options we tried.

  • Setting the property “security.auth.login.config” and “java.security.krb5.conf” inside the code using System.property by keeping kafka jaas.conf ,keytab in /etc/ folder.

 

  • We added the KafkaClient entry in hbase jaas.conf file having path /etc/hbase/conf/jaas.conf.

 

  • Kept Kafka jaas name as kafkajaas.conf and configured in hbase-env.sh having path /etc/hbase/conf in all the nodes.

 

  • In Cloudera Manager > HBase server set the property in “HBASE Client Advanced Configuration Snippet (Safety Valve) for navigator.client.properties”

As

export HBASE_OPTS="$HBASE_OPTS -Djava.security.auth.login.config=/etc/jaas.conf -Djava.security.krb5.conf=/etc/krb5.conf"

 and deployed the client configuration.

We checked the default value of property “java.security.auth.login.config” using System.getProperty, the value given as /var/run/cloudera-scm-agent/process/<<hbase process>

 

Could anyone help on this?

 

Regards

Gopa

Don't have an account?
Coming from Hortonworks? Activate your account here