Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Kerberizing HDP 2.x with JDK 1.8 fails

Kerberizing HDP 2.x with JDK 1.8 fails

Contributor

Kerberizing an HDP 2.x cluster with Active Directory and Ambari 2.x succeeds with JDK 1.7.

When we upgrade to JDK 1.8, it fails with the following error:

javax.naming.CommunicationException: simple bind failed:x.y.z:389 [Root exception is javax.net.ssl.SSLException: java.net.SocketException: Connection reset]

Anyone experienced this before?

Is there a specific release of JDK 1.8.x that we know works?

7 REPLIES 7

Re: Kerberizing HDP 2.x with JDK 1.8 fails

@Nasheb Ismaily

Where are you able to see this error ? I tested and HDP2.3 with kerberos and JDK1.8 it works for me.

Can you be specific about Ambari and HDP version you are using.

AD with SSL seems to be a problem. Please check link below -

https://community.hortonworks.com/questions/8652/connection-problem-with-kerberized-cluster-while-u....

https://developer.ibm.com/answers/questions/164608/what-is-causing-javaxnetsslsslexception-unsupport...

Re: Kerberizing HDP 2.x with JDK 1.8 fails

Contributor

Thanks Sagar,

This error appears in the ambari-server logs.

HDP Version: 2.3.2

Ambari Version: 2.1.2

Java Version: 1.8.x

I'll take a look at the links you posted

Re: Kerberizing HDP 2.x with JDK 1.8 fails

Sure. Please do let us know if the issue is resolved.

Re: Kerberizing HDP 2.x with JDK 1.8 fails

Guru

Do you have the JCE unlimited strength policy files as part of JDK 1.8 ? Can you also put the full stacktrace.

Re: Kerberizing HDP 2.x with JDK 1.8 fails

Contributor

Thanks Ravi,

I've attached the full stack trace. JCE has been installed on all nodes.

ambari-server-stack-trace.txt

Re: Kerberizing HDP 2.x with JDK 1.8 fails

New Contributor

Not sure what version of HDP you are using but this is known Apache bug HADOOP-10786. This issue is fixed in HDP 2.3 or later. If you are using HDP 2.2, please downgrade to JDK version 1.7 update 79 or earlier and it should work.

Re: Kerberizing HDP 2.x with JDK 1.8 fails

Contributor

Thanks Avinash,

They are using HDP 2.3.2 with Ambari 2.1.2

Don't have an account?
Coming from Hortonworks? Activate your account here