Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Keytabs are not creating for few nodes

Keytabs are not creating for few nodes

New Contributor

I have setup 10 nodes cluster and I kerberize the cluster, but 8 of them are working, but 2 nodes are not creating keytabs. I was trying to regenerate, but it is not picking up those 2 nodes.

How can I fix it?

8 REPLIES 8

Re: Keytabs are not creating for few nodes

Hi @Anpan K,

Is the two nodes having any HDP services or is it just a node added to ambari.

What is the error you are facing when trying to regenerate Keytabs ?

Is kerberos clients installed in your problamatic nodes ?

Is there any alerts or warnings related to this in your cluster.

Re: Keytabs are not creating for few nodes

New Contributor

These are worker nodes and datanode and nodemanagers are down due to kerberos, but other services are up and running.

Three is no error message, when I try to regenerate it is basically skipping those 2 nodes.

Yes, kerberos clients are installed already.

No alerts or warning about it.

Re: Keytabs are not creating for few nodes

Mentor

@Anpan K

Can you validate that the krb5.conf matches the rest of the working node? This is a file that has to be identical on all the nodes in the cluster.


Re: Keytabs are not creating for few nodes

New Contributor

Yes, file is identical to all other nodes.

Highlighted

Re: Keytabs are not creating for few nodes

New Contributor

Can I delete the host and add it again ? Would it help?

Re: Keytabs are not creating for few nodes

Mentor

@Anpan K

If they are datanodes then decommission and then add them to the cluster as a last resort. Will you clean them up before joining them to the cluster.

Before doing that can you check id the NTPD is running and those problematic datanodes are in sync [Time] with the rest?

Re: Keytabs are not creating for few nodes

Mentor

@Anpan K

Any updates? Do you still need help to resolve this issue?

Re: Keytabs are not creating for few nodes

Mentor

@Anpan K

Any update do you still need help with this issue?