Support Questions
Find answers, ask questions, and share your expertise

Knox only creates gateway for the Ambari UI, when I access other service UI's it diverts back to the standard IP/FQDN

HDP: 2.6.2.14-5

As the title suggests, Knox is only creating a gateway for ambari. If I access any other service UI it reverts back to the original IP. It doesn't seem to be mapping at all.

Taking YARN as an example, this is the config I have in the topology:

            <service>
                  <role>YARN</role>
                  <url>http://192.168.XXX.XXX:8088</url>
             </service>
             <service>
                   <role>YARNUI</role>
                   <url>http://192.168.XXX.XXX:8088</url>
            </service>
7 REPLIES 7

Super Mentor

@L V

Can you please change the IP Addresses with Host name of Yarn hosts?

Example:

   <service>
        <role>YARN</role>
        <url>http://<YARN_HOSTNAME>:<YARN_PORT></url>
    </service>
    <service>
        <role>YARNUI</role>
        <url>http://<YARN_HOSTNAME>:<YARN_PORT></url>
    </service>

.

If you are clicking on the Quicklinks on the ambari UI (in knox enabled cluster) and noticing that the URL is having changing to IP Address then please try the suggestion mentioned in : https://community.hortonworks.com/questions/88500/how-to-make-ambari-quick-links-to-point-to-knox-ga...

Or try changing the quicklinks.json https://cwiki.apache.org/confluence/display/AMBARI/Quick+Links

.

Hi @Jay Kumar SenSharma

Using the FQDN didn't work either. With quicklinks, the only files available are in these directories

/var/lib/ambari-agent/cache/common-services/

/var/lib/ambari-agent/cache/stacks/HDP/2.3/services/

/var/lib/ambari-agent/cache/stacks/BigInsights/4.2.5/services/

Which doesn't look right:

https://cwiki.apache.org/confluence/display/AMBARI/Quick+Links

"By default, the JSON file is called quicklinks.json and is located in the quicklinks directory under the service root directory. For example, for Oozie, the file is OOZIE/quicklinks/quicklinks.json. You can also name the file differently as well as put it in a custom directory under the service root directory."

Super Mentor

@L V

You can find the quicklinks json for YARN here: (On Ambari Server Host)

/var/lib/ambari-server/resources/stacks/HDP/2.0.6/services/YARN/quicklinks/quicklinks.json
/var/lib/ambari-server/resources/stacks/HDP/2.0.6/services/YARN/quicklinks-mapred/quicklinks.json
/var/lib/ambari-server/resources/stacks/HDP/2.3/services/YARN/quicklinks/quicklinks.json
/var/lib/ambari-server/resources/stacks/HDP/2.3/services/YARN/quicklinks-mapred/quicklinks.jso

.

Hi @Jay Kumar SenSharma

Do I need to change the quicklink in all of the above listed locations?

Super Mentor

@L V

Yes, in the above list of files 2 are for mapreduce as well.

but if you want it only for Yarn components then the following two files. (After making changes it should be followed by ambari-server restart)

/var/lib/ambari-server/resources/stacks/HDP/2.0.6/services/YARN/quicklinks/quicklinks.json
/var/lib/ambari-server/resources/stacks/HDP/2.3/services/YARN/quicklinks/quicklinks.json

.

But recommended will be to change on all yarn quicklinks

Hi @Jay Kumar SenSharma that worked!

Although it throws a browser popup asking me for a username and password - admin/admin doesn't work nor does the Knox master secret password work and I don't recall setting any other authentication credentials. Are additional authentication configs required?

Thanks for that @Jay Kumar SenSharma

I made the following changes:

  {
        "name": "resourcemanager_ui",
        "label": "ResourceManager UI",
        "requires_user_name": "false",
        "component_name": "RESOURCEMANAGER",
        "url": "https://FQDN(KNOX HOST):8443/gateway/default/yarnui",
        "port":{
          "http_property": "yarn.resourcemanager.webapp.address",
          "http_default_port": "8088",
          "https_property": "yarn.resourcemanager.webapp.https.address",
          "https_default_port": "8090",
          "regex": "\\w*:(\\d+)",
          "site": "yarn-site"
        }
      },<br>

Still no luck. - I restarted both ambari server and the ambari agent for the YARN host.

; ;