Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Limit Hive LLAP port range for connecting to datanodes

Limit Hive LLAP port range for connecting to datanodes

New Contributor

I'm currently running into an issue when starting up Hive LLAP. It appears to fail because it is attempting to connect to the data nodes using a blocked port. I'd like to limit the allowed port range for LLAP.

I tried adding site.global.slider.allowed.ports to slider-client.xml but it did not appear to work. Am I trying to set the wrong property? Am I adding the property to the wrong file?

Sidenote:

I already successfully setup Yarn and Tez to use this port range utilizing the following properties:

  • yarn.app.mapreduce.am.job.client.port-range
  • tez.am.client.am.port-range
  • tez.am.task.am.port-range
4 REPLIES 4

Re: Limit Hive LLAP port range for connecting to datanodes

Can you please post the stack trace you are seeing?

Re: Limit Hive LLAP port range for connecting to datanodes

@Namit Maheshwari

This is a comment not an answer. Should be moved to a comment.

Re: Limit Hive LLAP port range for connecting to datanodes

Rising Star

You should set the site.global.slider.allowed.ports property in the global section of the appConfig.json. LLAP appears to have a CLI option slider-appconfig-global that will add custom properties.

Highlighted

Re: Limit Hive LLAP port range for connecting to datanodes

Rising Star

> I'd like to limit the allowed port range for LLAP.

LLAP does not use the Slider port assignment scheme and instead pulls it from hive-site.xml (the interactive one)

Here are the port numbers and configs you might want to whitelist.

  • hive.llap.daemon.yarn.shuffle.port (15551)
  • hive.llap.daemon.web.port (15002)
  • hive.llap.daemon.rpc.port (0)

The last rpc port is likely where you're seeing issues because it is unassigned by default.

Also any tez changes you make need to go into tez_hive2/conf/tez-site.xml as well.