Support Questions
Find answers, ask questions, and share your expertise

Loading tpc-h data error


I'm trying to use the following repo to build and load tpc-h data into hdp:

I ran ./ and it was executed successfully, but when I tried to run ./ 2, I got the following error:

18/01/14 15:07:09 ERROR hdfs.DFSClient: Failed to close inode 38075
org.apache.hadoop.ipc.RemoteException( File /tmp/all_2-1515942428 could only be replicated to 0 nodes instead of minReplication (=1). There are 1 datanode(s) running and no node(s) are excluded in this operation.
at org.apache.hadoop.hdfs.server.blockmanagement.BlockManager.chooseTarget4NewBlock(
at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getNewBlockTargets(
at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getAdditionalBlock(
at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.addBlock(
at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.addBlock(
at org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(
at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$
at org.apache.hadoop.ipc.RPC$
at org.apache.hadoop.ipc.Server$Handler$
at org.apache.hadoop.ipc.Server$Handler$
at Method)
at org.apache.hadoop.ipc.Server$

at org.apache.hadoop.ipc.Client.getRpcResponse(
at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(
at com.sun.proxy.$Proxy10.addBlock(Unknown Source)
at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolTranslatorPB.addBlock(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at com.sun.proxy.$Proxy11.addBlock(Unknown Source)
at org.apache.hadoop.hdfs.DFSOutputStream$DataStreamer.locateFollowingBlock(
at org.apache.hadoop.hdfs.DFSOutputStream$DataStreamer.nextBlockOutputStream(
at org.apache.hadoop.hdfs.DFSOutputStream$
ls: `/tmp/tpch-generate/2/lineitem': No such file or directory

Anyone can help?



@Mohammed Syam

Error is at time of writing a file in HDFS : 'File /tmp/all_2-1515942428 could only be replicated to 0 nodes instead of minReplication (=1). There are 1 datanode(s) running and no node(s) are excluded in this operation.'

Your HDFS space might be full (you only have 1 datanode) or your user is not granted write on /tmp or /tmp/tpch-generate.

Run hadoop dfsadmin -report to check HDFS status and hdfs dfs -ls /tmp/* to check rigths.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.