Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Lock on /hadoopfs/fs1/hdfs/namenode/in_use.lock acquired by nodename [email protected] 2021-08-11 06:30:25,079 WARN namenode.FSNamesystem (FSNamesystem.java:loadFromDisk(716)) - Encountered exception loading fsimage java.io.IOException: NameNode is not formatted.

avatar
Explorer

Lock on /hadoopfs/fs1/hdfs/namenode/in_use.lock acquired by nodename [email protected] 2021-08-11 06:30:25,079 WARN namenode.FSNamesystem (FSNamesystem.java:loadFromDisk(716)) - Encountered exception loading fsimage java.io.IOException: NameNode is not formatted.

 

When i tried to format the namenode by using hadoop namenode -format 

getting the below error as,

 

21/08/11 06:45:12 INFO util.ExitUtil: Exiting with status 1: org.apache.hadoop.hdfs.qjournal.client.QuorumException: Could not format one or more JournalNodes. 2 exceptions thrown:
10.80.60.88:8485: Directory /hadoopfs/fs1/hdfs/journalnode/dev-30 is in an inconsistent state: Can't format the storage directory because the current directory is not empty.

 

In hdfs-site.xml:

<property>
<name>dfs.data.dir</name>
<value>/hadoop/hdfs/data</value>
<final>true</final>
</property>
<property>
<name>dfs.name.dir</name>
<value>/hadoopfs/fs1/hdfs/namenode</value>
<final>true</final>
</property>

 

Please help me on above issue.

2 REPLIES 2

avatar
Rising Star

It is worth checking the content under 

/hadoopfs/fs1/hdfs/journalnode/dev-30

Kindly confirm whether there is any unwanted file/dir which might be causing this error.

avatar
Community Manager

@ManjuN, Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future.  If you are still experiencing the issue, can you provide the information @Asok  has requested?



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: