Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Login button not visible on Zeppelin 0.6?

Re: Login button not visible on Zeppelin 0.6?

New Contributor

Hi,

I have followed above steps given in the url..

Still it is not working..

Thank you in advance

Re: Login button not visible on Zeppelin 0.6?

Rising Star
@vshukla

Can you confirm if this is expected to work on HDP 2.4.0 Zeppelin? This link suggests it should, but I'm hitting the same error as described above. I've been able to reproduce the issue on a HDP 2.4.0 sandbox and also a new install of HDP 2.4.0 using Zeppelin that is provided with in the HDP repo.

Re: Login button not visible on Zeppelin 0.6?

Not sure if this works with 2.4.0. But with 2.4.2 it works.

Re: Login button not visible on Zeppelin 0.6?

@Laurence Da Luz Pl post your shiro config, is it configured for authcBasic or authc?

Re: Login button not visible on Zeppelin 0.6?

Rising Star

@vshukla

I've attempted this using the same configuration as @Manoj Dhake. Please see the following link for shiro.ini:

https://community.hortonworks.com/storage/attachments/4888-shiro-content.txt

This was using authcBasic. Note though, I've also attempted the configuration using authc and experienced the same issue (no login prompt displayed). There seems to be no impact to Zeppelin at all when changing this shiro.ini file and restarting (I had tried both local user config & LDAP configuration). Is there a way to confirm that this shiro.ini file is actually being read?

Re: Login button not visible on Zeppelin 0.6?

Please post the path of the shiro config that you are using? Also turn on Zeppelin logging and post the debug logs.

Re: Login button not visible on Zeppelin 0.6?

New Contributor

Path of shiro.ini:

/usr/hdp/current/zeppelin-server/lib/conf/shiro.ini

log: zeppelinlog.txt

Re: Login button not visible on Zeppelin 0.6?

New Contributor

@Manoj Dhake....I am not sure if your issue is resolved or not but I resolved the same by doing below and after doing below I could see the Login Buttion and I could successfully login to Zeepelin notebook with AD user.

Change below in Zeepelin Notebook => Configs

shiro_ini_content:

[urls] # anon means the access is anonymous. # authcBasic means Basic Auth Security # To enfore security, comment the line below and uncomment the next one

/api/version = authcBasic

#/** = anon

/** = authc

Highlighted

Re: Login button not visible on Zeppelin 0.6?

@HadoopAdmin India

To enable login to Zeppelin in HDP 2.5, below are the changes I had to make to Ambari > Zeppelin > Configs > zeppelin-env > shiro_ini_content

1. Uncomment admin line (by removing #) and set to your password

#admin = password1 

to

admin = mysecurepassword

2. Uncomment any lines starting with #sessionManager or #securityManager

3. Uncomment authc line by changing:

#/** = authc

to:

/** = authc

4. Comment out anon line by changing:

/** = anon 

to

#/** = anon

Here is a script to automate this using config.sh. Run it from Ambari host (but first change ambari_user, ambari_password, cluster_name, zeppelin_host per your environment)

ambari_user=admin
ambari_password=admin
cluster_name=hdp
zeppelin_host=host3.cloud.com

cd /var/lib/ambari-server/resources/scripts/

#create zeppelin-env.json with updated configs
 ./configs.sh -u ${ambari_user} -p ${ambari_password} get localhost ${cluster_name} zeppelin-env   | sed -e '1,3d' \    
-e "/^\"shiro_ini_content\" : / s:#admin = password1:admin = ${ambari_password}:"  \    
-e "/^\"shiro_ini_content\" : / s:#sessionManager:sessionManager:" \    
-e "/^\"shiro_ini_content\" : / s:#securityManager:securityManager:" \    
-e "/^\"shiro_ini_content\" : / s:#securityManager:securityManager:" \    
-e "/^\"shiro_ini_content\" : / s:/\*\* = anon:#/\*\* = anon:" \    
-e "/^\"shiro_ini_content\" : / s:#/\*\* = authc:/\*\* = authc:"  > /tmp/zeppelin-env.json

#write updating configs to Ambari
./configs.sh -u ${ambari_user} -p ${ambari_password} set localhost ${cluster_name} zeppelin-env /tmp/zeppelin-env.json

#restart Zeppelin

curl -u ${ambari_user}:${ambari_password} -H 'X-Requested-By: blah' -X POST -d "{   \"RequestInfo\":{      \"command\":\"RESTART\",      \"context\":\"Restart Zeppelin\",      \"operation_level\":{         \"level\":\"HOST\",         \"cluster_name\":\"${cluster_name}\"      }   },   \"Requests/resource_filters\":[      {         \"service_name\":\"ZEPPELIN\",         \"component_name\":\"ZEPPELIN_MASTER\",         \"hosts\":\"${zeppelin_host}\"      }   ]}" http://localhost:8080/api/v1/clusters/$cluster_name/requests