Support Questions
Find answers, ask questions, and share your expertise

Metadata not being captured by ATLAS_HOOK HDP 2.6

Solved Go to solution

Metadata not being captured by ATLAS_HOOK HDP 2.6

Contributor

Env: HDP 2.6

Kerberos enabled

Atlas added as a service post upgrade.

Metadata is not visible from Atlas UI. Tried consuming the messages from beginning for the topic ATLAS_HOOK and this doesn't have any messages.

However, I can see the list of entities and when queried for the entities, I can see them in kafka-logs (grep with entity name and result shows the recent .log files matches).

Ranger plugin for kafka is not eabled and shen searched for ACL's, all users have write access from all hosts for the topic.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Metadata not being captured by ATLAS_HOOK HDP 2.6

Expert Contributor

@sundara Palanki

which entities types of entities you are referring to, if hive did you try import-hive.sh script or create table in hive db.

check the hive and atlas application logs for error during table creation time.

View solution in original post

4 REPLIES 4
Highlighted

Re: Metadata not being captured by ATLAS_HOOK HDP 2.6

Mentor

@Sundara Palanki

You should enable the Ranger Kafka hook,restart all stale configs and retry

Highlighted

Re: Metadata not being captured by ATLAS_HOOK HDP 2.6

Contributor

@Geoffrey Shelton Okot The authorizer class is set to simpleAuthorizer* and why should I have the ranger plugin for kafka enabled ?

Highlighted

Re: Metadata not being captured by ATLAS_HOOK HDP 2.6

Expert Contributor

@sundara Palanki

which entities types of entities you are referring to, if hive did you try import-hive.sh script or create table in hive db.

check the hive and atlas application logs for error during table creation time.

View solution in original post

Highlighted

Re: Metadata not being captured by ATLAS_HOOK HDP 2.6

Contributor

@Nixon Rodrigues The problem was with the initial import where atlas user doesn't have read/execute on /apps/hive/warehouse. Once I added the policy for atlas user and ran the script, I was able to get everything in place.

Don't have an account?